0 Replies Latest reply on Jan 18, 2018 4:52 AM by goger

    system has detected a link failure and cannot set the requested resolution

    goger

      Hi,

       

      about three weeks ago I had a problem with my PC:

       

      When i started the PC I get the message

       

      "system has detected a link failure and cannot set the requested resolution ..."

       

      from the AMD Settings Tool.

       

      Before that the system worked fine for over a year and I am not aware of something I did that could have caused the issue. That time I was able to resolve the problem by switching to an older system restore point. The restore point was from a windows update installation of a vga driver for the chipset of my i5 processor. When I siwtched back I noticed that I had a new problem which first occured after the creators fall update: The monitor was way too dark. This can be solved by running the color calobration of windows 10.

       

      Since this, the error didn't show up again until yesterday.

       

      I have exactly the same problem. So I tried the last restore point. This time it didn't fix the problem. The restore point I used was from a program installation. It seems as if this does not fix the affected files. I noticed that after restoring the brightness problem didn't occur again this time, so it did something different than when I restored the first time the problem occured. Unfortunately that restore point is not available anymore.

       

      More things I noticed:

      - freesync is only recognized for 55-59Hz although the display can do 144hz

      - freesync doens't work anymore, tested it with the windmill demo. Last time I tested it, it was ok (but this is half a year ago, so I am not sure if the problems are related)

      - device manager says monitor is not migrated, but I am not sure if this is normal and unrelated

      - the error message is gone when i disable DP1.2 in the monitor, but freesync still doesn't work and I believe DP1.2 is necessary for freesync

       

      I am 100% sure that this is a software issue because the system worked fine and last time a software change removed the problem, unfortunately I am not able to find out what I have to do this to get rid of this error. I really don't want to reinstall the system, because I am not sure if this would fix it, might be related to some windows update?

       

      What I have tried so far:

       

      - uninstall AMD driver including registry cleanup followed by

      - install of latest driver

      - uninstall of monitor driver

      - uninstall of unused monitors in device manager (i have no idea why but there were quite a few of them)

      - reinstall of monitor driver

      - power off/on

      - display port cable reconnect

       

      My system:

       

      CPU: i5-6600k

      Mainboard: Asus Z170-A

      RAM: 16GB

      primary monitor: LG 34uc79g-b connected via DP

      secondary monitor: benq gl2450 connected via dp to dvi

      Windows 10 64-Bit

       

      I hope someone has any idea what is going on.

       

      Thakn you very much.

       

      Best regards.