9 Replies Latest reply on Jan 21, 2018 7:21 PM by goodplay

    AMD Radeon Setting won't openr5 m335 Win 10 17.2.1

    beepboop

      System:

      • AMD Graphics Card
        • AMD Radeon R5 M335
      • Desktop or Laptop System
        • Laptop- Dell Inspiron 5559
      • Operating System
        • Windows 10 Home 64bit
      • Driver version installed
        • Adrenalin Edition 17.12.1
      • Motherboard + Bios Revision
        • Don't know what the motherboard is. Bios Version is Dell Inc 1.4.1 08/12/2017 (I don't know why it has this date, as I installed the latest bios released on the 8th of Jan to protect against Spectre/Meltdown.)
      • CPU/APU
        • Intel Core i5-6200U
      • RAM
        • 8GB

       

      I hope I've included all relevant info correctly here.

       

       

      Ok, on the 12th of Jan, I used the Dell website to check for updates as I wanted the Bios that protects against Spectre/Meltdown and the Dell update program on my computer wasn't giving me any new updates. The Dell website said there were four updates that I needed, one of which was an update for Radeon (this one here AMD Radeon R5 M335/M315 Driver Driver Details | Dell Australia)

       

      I decided to first check AMD Radeon Settings for updates as I hadn't received any update notifications in a while but it would not open. So I went ahead and let the Dell website install the update it suggested. After completion, AMD Radeon Settings still wouldn't open.

       

      I then found kingfish's instructions (here Clean Install AMD Graphics Drivers) and followed them.

       

      I used the Reg edits method described in Option four here Windows 10 Forums and the Control Panel method described in Option one here Windows 10 Forums to prevent/delay Microsoft automatically changing/installing graphics drivers.

       

      There was only one AMD program listed under Add/Remove Programs but I couldn't uninstall it as it kept crashing as soon as I tried to.I can't remember what it was called but it was removed once I ran DDU. I also found AMD Problem Report Wizard in the Start Menu and used the Uninstall option there for it.

       

      Now that I had completed kingfish's instructions, I installed Adrenalin Edition 17.12.2 (which is currently listed as optional).

       

      After completion, AMD Radeon Settings was opening, appearing in the tray and working fine.

       

       

      Then yesterday, the 13th of Jan, I turned on my laptop to find that AMD Radeon Settings was now once again not opening.

       

      This time i only ran DDU and deleted the files out of the AMD folder while my internet connection was disabled before trying installing Adrenalin Edition 17.12.1 this time.

       

      After completion, AMD Radeon Settings was once again opening, appearing in the tray and working fine. However, after an unknown amount of time, it disappears from the tray and will no longer open. I decided to leave it for the night and see if it worked the next day.

       

       

      Today, I turned on my laptop and AMD Radeon Settings is still not opening.

       

      I tried running the DISM command and SFC command described here Troubleshooting Common AMD Graphics Driver Installation Problems but those didn't find anything or help.

       

       

      I've checked task manager to see what actually happens when I try opening AMD Radeon Settings and "Radeon Settings: Host Application" and "Radeon Settings: Command Line Interface" both appear for a few seconds before disappearing.

      "AMD External Events Client Module" and "AMD External Events Service Module" are always in task manager but I don't know if that information helps.

       

       

      Does anyone here know what the problem is. Any help would be greatly appreciated.

       

      I'd like to apologise for the long wall of text. I hope I've included all relevant and helpful information.

       

       

      Oh, by the way, in some older threads on the forum here where people were facing similar problems, I noticed it was suggested to check if .Net Framework and Visual C++ were installed and up to date. Is this something I should look at? I know that I have the latest version of .NET Framework (4.7.1) but Visual C++ is confusing and overwhelming. I have a whole bunch of different Visual C++'s installed and don't know how to check what's missing or needed.

       

      Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.