krish_geta

Blackscreen during driver installation & How to reset AMD 7670m clocks(misbehaviour)?

Discussion created by krish_geta on Jan 5, 2018

Describe your system:

  • Samsung NP350V5C-S02IN
  • Intel Core i5 3210m
  • RAM 4GB
  • Integrated GPU (Intel HD 4000)
  • Dedicated GPU (AMD Radoen 7670m)
  • Windows 10 64bit

 

Describe your issue:

NOTE : - I have never tried to overclock my GPU.

Suddenly my Samsung np350v5c-so2in screen got stucked  & after it I am unable to restart it but after a while I am able to start my laptop in safe-mode and uninstall drivers with the help of DDU(Display Driver Unistaller), Then drivers revert back to "Microsoft Basic Display Adapter" and a yellow mark on one driver as shown below

device manager 7670m.png

Then when I am trying to install driver for intel HD 4000 it installed successfully but after restart my laptop screen freeze's so I replay all steps and get back to "Microsoft Basic display Adapter".

and then I try to install amd 7670m driver(Latest one and old one too) and got stucked with a black screen then again I replay all steps and get back to "Microsoft Basic display Adapter".

Then somehow I found this post

Blackscreen crash on install/win logon on any AMD driver (HW PROBLEM)(FIX FOUND)  and here by resetting the clocks will solve the blackscreen issue but I am unable to extract the bios of my amd & GPU-Z shows very weird info as shown in the attachment below : -

 

amd 7670m_gpuz_details.gif

amd 7670m_gpuz_Sensors.gif

I know there is something wrong with the clocks and temperature goes like crazy and for more info here is the intel HD 4000 which looks fine

Intel HD 4000_gpuz_details.gif

So is there any way to reset my clock or my AMD 7670m is bricked? and I tried all of the drivers version almost and same results with all as well.

Outcomes