AnsweredAssumed Answered

DX11 Applications crash on 17.11.1 and above for A8-6410 APU with R5 M230

Question asked by raienryu97 on Jan 2, 2018
Latest reply on Feb 2, 2018 by raienryu97

Hello.

 

 

My Configuration

==============

Lenovo G50-45 Laptop AMD A8-6410 APU with Radeon R5 M230 as Primary and HD 8500 M as the discrete.

8 GB RAM

 

Issue

======

Immediate Crash on all tested DX 11 Applications, they simply crash on launch. Do not even load. Non OC'ed .

 

Event Viewer Log

================

Faulting application name: heaven.exe, version: 1.0.0.0, time stamp: 0x511b9e02

Faulting module name: aticfx32.dll, version: 23.20.788.0, time stamp: 0x59fb6507

Exception code: 0xc0000005

Fault offset: 0x00041ec4

Faulting process id: 0x239c

Faulting application start time: 0x01d383b5e8b8854a

Faulting application path: C:\Program Files (x86)\Unigine\Heaven Benchmark 4.0\bin\heaven.exe

Faulting module path: C:\Windows\System32\DriverStore\FileRepository\c0320046.inf_amd64_8e8f6af872d98101\aticfx32.dll

The above log is from the 17.11.1 - Nov 10 driver , but the crash logs are same on all drivers on and above this version.

 

Tested Apps

==========

Uningine Valley, Uningine Heaven benchmarks and Tom Clancy's Rainbow Six Siege

 

Isolation Done

============

Siege doesn't start, simply crashes. Benchmarks run fine on OpenGL mode or DX 9 mode, only crashes on DX 11 mode immediately on start.

 

Tried Recommendations

===================

Clean install, used AMD clean install, display driver uninstaller and also ( Just as a sanity check ), a clean windows install.

 

 

Driver Versions

============

17.7.2 - July 27 to be the last working version. Every driver above that if i remember correctly has this issue,including the Adrenaline Release.

 

I have already contacted the AMD tech support regarding this, and after around 7 e-mail exchanges with me mentioning repeatedly that I would love to be able to use newer drivers, I was finally requested to use the driver that my manufacturer releases. Unfortunately that driver has horrible performance and is a 17.1.1 driver. Way too old. I am putting the post here after a lot of trials from my side in the hope that someone could maybe help me debug this, it could still be an issue on my side, and help me use newer drivers on my laptop or ( in the unlikely case ) if it is an AMD driver issue, someone from the team could fix it on their end. I know I am using a crappy laptop and a very low end GPU, but any help at all would be very very appreciated.

Thanks.

Outcomes