4 Replies Latest reply on Feb 20, 2018 7:41 AM by narkotine

    Compute mode won't stay on one card

    narkotine

      Hi, I have 6 RX580, win10, 17.12.2 drivers, every card on his pcie1.0 riser.

      One card won't stay on compute mode after the drivers reboot, it comes back to graphics.

      It is noticeable that this the card wich riser is on the PCIe 16x original port.

      On other computers this gpu had no pb and on another computer, on real pcie16 port there was no issues with the compute mode.

       

      Any way to fix this ?

      ty

        • Re: Compute mode won't stay on one card
          elstaci

          I am not a miner but found this. I am almost certain you have the "Computer Workload Options" checked but just in case:

          GPU Workload

           

          A new toggle in Radeon Settings that can be found under the "Gaming", "Global Settings" options. This toggle will allow you to switch optimization between graphics or compute workloads on select Radeon RX 500, Radeon RX 400, Radeon R9 390, Radeon R9 380, Radeon R9 290 and Radeon R9 285 series graphics products.

           

          Compute Support

           

          Radeon Software now supports compute workloads for up to 12 installed Radeon RX 400, Radeon RX 500 or Radeon RX Vega series graphics products on Windows®10 system configurations.

           

          or from this copy of another webpage concerning Cryptomining:

           

           

          • Re: Compute mode won't stay on one card
            narkotine

            In short, the solution is a reg file that looks like this :

             

            Windows Registry Editor Version 5.00

             

             

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0001]

            "KMD_EnableInternalLargePage"=dword:00000002

             

             

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0002]

            "KMD_EnableInternalLargePage"=dword:00000002

             

             

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0003]

            "KMD_EnableInternalLargePage"=dword:00000002

             

             

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0004]

            "KMD_EnableInternalLargePage"=dword:00000002

             

             

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0005]

            "KMD_EnableInternalLargePage"=dword:00000002

             

             

            [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\0006]

            "KMD_EnableInternalLargePage"=dword:00000002