AnsweredAssumed Answered

VCE firmware bug?

Question asked by jpsollie on Dec 30, 2017
Latest reply on Jan 3, 2018 by jpsollie

happy 2018 everyone!

I'm trying to recode an MPEG2 movie to H264 using the AMD VCE on gentoo linux/ ffmpeg/vaapi/amdgpu

when using the baseline or main profile, everything seems to go well (using sufficient switches, such as disabling B-Frames).

This is not the case with the high profile: it uses the separate colorplanes feature, making it unplayable on another PC.

I do not think this is a ffmpeg problem, as libx264 works perfectly on all profiles.

I do not think this is a software problem, as I do not pass by the CPU recoding the MPEG2 stream (the hardware decodes the MPEG2 stream, and recodes it to H264, no software filters are applied, so the content should stay in GPU memory), and the recoding for the Baseline and Main profiles works perfectly.

- Is this a firmware bug?

- Is this a driver bug?

 

Any information is appreciated, I am willing to help searching the code for the profile -> feature part of the process, but I have no idea where it is done:

- FFMPEG (tried the 3.3 and 3.4 series)

- libva (tried the 1.7, 1.8 and 2.0 series)

-linux amdgpu kernel driver (4.14.8)

-amdgpu firmware (no idea at all, I do not have the sources)

- Tonga/Fiji BIOS (yes, tried both of them)

Thank you

Outcomes