5 Replies Latest reply on Dec 28, 2017 3:11 PM by ray_m

    ASUS Prime B350M-E does not boot with Ryzen 5 1600 (SOLVED)

    patience.me

      Configuration

      CPU: AMD Ryzen 5 1600

      RAM: Corsair Vengeance LPX 8GB (2x4GB) DDR4 DRAM 2400MHz (PC4 19200) C16 Memory Kit - Black (CMK8GX4M2A2400C16)

      Mobo: ASUS Prime B350M-E

      PSU: GTR Type-R 500 500W

      HDD: WD20EZRZ 2TB (Not new)

       

       

      I recently purchased this motherboard. However after installing the RAM and CPU, which I purchased together with the motherboard, the motherboard did not boot up (D-sub port connected to monitor). There was no warning sound, no warning light. The CPU fan started spinning but there was no signal to the monitor. I disconnected the HDD but the motherboard still did not post. Then I tried with only 1 of 2 RAM to no avail. I even re-seated the CPU but nothing worked. I attached 2 pictures (before and after power on) to show the light status on the board. Now the red lights just slowly blink after power on. Appreciate if someone could point me to the right direction. Thank you.