0 Replies Latest reply on Dec 25, 2017 12:54 AM by xtriker

    Help! I can't play with my new RX 570

    xtriker

      So basically the first thread is here: https://www.reddit.com/r/Amd/comments/7l4k12/help_i_cant_play_with_my_new_rx_570/

      Now, I would like to give any information I have in order to solve this problem:

      (throwback a few months ago) - I was able to play AC Unity on my PC with really low settings, but I decided to stop there and continue when I'd get a new GPU(if I was ever to get one). Over the last year, me and my parents have been financially struggling, but I've managed to save some cash every month and kept it in the bank.

      So, December comes, my dad manages to get some money from work (he told me that it was because I made him proud for being admitted a great college), and he tells me that he wants to buy me that GPU I've been dreaming about. The fact is that my PC had received a great improvment ~2 years ago, when I turned 18yo. One of my friends, who's playin in a LoL eSports team had updated his PC to Skylake, and he gave me as a birthday present his 16GB of RAM. The second most amazing gift was a new montior(I had a 4:3 Phillips monitor since 2005), a FreeSync-enabled Samsung monitor. That's when I decided that I would stick with AMD.

      Moving on, I finish my mid-terms and then I go home. The next day, the RX 570 arrives(Keep in mind that I had installed the same OS from the time I played AC Unity). I retire the old 7770 and install the new GPU. I reinstall the drivers, and everything looked OK. After that, I install the one game I've been waiting to play. I launch in, watch the first cinematic of the game, and then, when it comes to moving the character, it freezes. The image froze, and then I got a black screen. I hardly manage to close the game because I am not able to see the mouse cursor. At first I thought that it was a simple error, but it happened again, and again, and again. After that I tried playing other games.

      Games that worked: FIFA, DOTA2, Mafia 3 and Watch Dogs

      Games that did not work: AC:Unity, Wildlands, Wolfenstein: The New Order(it partially worked, I got a few crashes at first, but then I managed to play a bit form the first mission, BUT THEN IT STARTED TO CRASH AGAIN. That's when I said: "Screw it".

      I decide to do a clean install on Windows. Same old. And I did it about 4-5 times, with different settings, trying the latest drivers and even the drivers that Windows10 installs in background(17.7). The same happened. Games that I've also tried during this period: AC Syndicate - I manage to play about ~30-40 seconds in the first mission, when you're in the factory, but when I interact with an object, the same happens. The other thing that annoyed me was that I would get the RADEON SETTING HOST APPLICATION HAS STOPPED WORKING after a freeze, altough it happened 6/10 times.

      Fast-forward a few days ago, I decide to get some help from a buddy of mine. He comes to my place, we reinstall the windows and get the latest drivers (Yes, I've also used DDU the proper way), but the same thing happened with Unity. Altough this Windows10 feels much much better than the rest I've tried (I managed to properly install AORUS GRAPHICS ENGINE, a thing that I wasn't able to do with the other versions of Windows). The same thing happens with Unity, but I also got a crash from Watch Dogs 2, and CoD:WWII gave me a freeze after I changed the type of shadows in the settings menu. At the moment, I am able to play both Watch Dogs and COD, but I know that something is really wrong. AC4 crashed at first, but then it worked. The reason I am so mad about this is that I've put my parents in a position where they had to struggle to keep me in college(I never go out clubbing because I end would easily end up spending ~15 euros, and I don't want to do that) and they've made lots of compromises in order to give me what I've wanted for Christmas. I feel really guilty now seeing that all the money that we've saved over the last yeas was spend for something I really wanted but does not work as intended.

      Now, I'm asking you to help me out, because I've tried so many things and I feel like weird when my parents come in my bedroom and ask me if I like the new graphics card, and I tell them that it's great. I hate lying to them.

      THINGS THAT YOU SHOULD ALSO KNOW:

      • I've tried benchmarks and stress tests(Unigine, 3DMark & Furmark). No crash whatsoever and no freezes. I've also tried checking the HDD and the RAM. The HDD is ok, and Windows' Memory Diagnostic showed no error.
      • For whatsoever reason, Freesync doesn't seem to work in games, but it kinda worked in the Windmill demo. I can not see any difference in the windmill demo, but I see that it works with that red line, even tho' it felt really, really slow (my Freesync range is 48-72 Hz).
      • PC specs: FX-6300, ASROCK 970DE3/U3S3, 16GB of RAM @ 1333MHz, AORUS RX 570, WD 500GB HDD, Seasonic M12II-620 EVO.