1 Reply Latest reply on Dec 28, 2017 2:09 PM by ray_m

    rx 550 not working properly

    igorogomes

      First my specifications are:

      ASUS Radeon RX 550 4GB

      Desktop Windows 7 Ultimate - 64 bits

      Crimson ReLive 17.12.1

      GA G41MT S2P (rev 1.3)

      Intel Core 2 Quad Q9550 2.83 GHz

      PSU 500w

      8GB RAM

       

      I recently upgrade my Graphics from a HD Radeon 6570 to a Radeon RX 550, so I upgraded to Windows 10 64bits before installing the RX 550 and for the first two weeks it worked better than I expected, I was able to run Dota 2 on the highest graphics at 60 fps, Overwatch and WoW graphics set on high but also running 60fps. But suddendly I started receiving an error on Overwatch: "The rendering device has been lost". After some research on the Blizzard's community I found out that this is happening quite often with AMD users and I tried every procedure Blizzard gave me, including the driver downgrade to 17.7.1, but none of those were effective. Now I even tried going back to windows 7 64bits and also updating the drivers to the latest released ( 17.12.1) that should work, according to Blizzard in a recent update to the community. Again, didn't work and now not only Overwatch but every game that I tried have lower fps then before.

       

      What I want to know if this have happened because of my specs been old (motherboard only has drivers until Windows 7, reason why I went back to the 7) and not fully compatible with the graphic, the many procedures have damaged it or if the graphic already came deffective.

       

      Just to add, I looked the requeriments before the purchase and seemed to be attended by my specs. Also, I have the warranties from both the store and the own product itself.

      I always had AMD graphic cards and never had any problem, so I hope someone can help me with this issue and this is a valid question for the forum.

      Thank you.