AnsweredAssumed Answered

Install stuck on Please wait while detecting hardware

Question asked by kerfluffle on Dec 18, 2017
Latest reply on Mar 30, 2018 by plumboby

Describe your system:

  • AMD Graphics Card
    • AMD Radeon HD 7850
  • Desktop or Laptop System
    • Custom Desktop
  • Operating System
    • Windows 7 64bit
  • Driver version installed
    • Attempting to clean install Adrenalin 17.12.1
  • Display Devices
    • Hanns-G HH241 Connected via hdmi to AMD card
    • Acer X223W connected via DVI to AMD card
  • Motherboard + Bios Revision
    • Asus P8Z77-V
  • CPU/APU
    • Intel Core i5-3470 Ivy Bridge
  • Power Supply Unit  Make, Model & Wattage
    • Antec TRUEPOWERII TPII-550
  • RAM
    • 8GB Corsair DDR3 1600

Describe your issue:

  • Provide a detailed description of the issue you are experiencing and the steps required to reproduce the issue.
    • I cannot clean install 17.12.1 on my system. The installer is stuck on "Please wait while detecting hardware..."
    • Installer.log always stops here:

                    CDCMPCIDriver::[000000000917E7E0] LoadDriver starting...

                    CDCMPCIDriver::[000000000917E7E0] Loaded Detection Driver successfully

      • I have let this run overnight.
      • I have tried DDU and AMD clean utility in safe mode several times.
      • I have run chkdsk and sfc /scannow
      • I have disabled anti-virus.
      • I selected PCIe card as primary in BIOS.
      • I have disconnected secondary monitor.
      • I have checked my registry at HKey_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ATI Technologies for any entries that need deleting. (There were none.)
      • I can successfully manually load the 17.12.1 drivers in device manager after DDU. I've unsuccessfully tried installing the AMD software with and without manual drivers loaded.
      • I can successfully install 17.11.4 drivers software. The AMD software in this version hangs when attempting to update to 17.12.1.
  • Details about applications/games affected (including version number)
    • This discovery began when Wolfenstein 2 would no longer load all of a sudden when using 17.11.4. It attempts to load, the screen goes black, and then returns to desktop. I then attempted to update to AMD latest drivers 17.12.1 but can only do manual install without the full software package. Now when attempting to load Wolfenstein 2 from executable I get the error vulkan-1.dll is missing from your computer (because full software did not install it).
  • Graphical settings used in the application/game (resolution and 3D settings)
    • N/A
  • If possible, include a screenshot or video link of the issue

Attachments

Outcomes