4 Replies Latest reply on Dec 17, 2017 8:22 PM by kaeoschassis

    Code 43 errors on ASUS laptop with AMD RX460

    kaeoschassis

      Hello,

       

      I recently purchased a new laptop, and I'm having issues with installing the graphics drivers. I've tried several times, but on each attempt after the drivers are installed, the device manager states that the graphics card has "reported problems" and been stopped (code 43). In fact two graphics devices are listed (I assume the APU and the dedicated graphics card?), and both report this same error.

       

      The specs of the laptop are as follows -

       

      Laptop: ASUS K550I

       

      CPU: AMD Quad-Core FX9830P

       

      RAM: 8GB

       

      Graphics Card: As far as I'm aware it's a AMD Radeon RX 460

       

      OS: Windows 10 64bit

       

      Driver version: Radeon Software Adrenalin Edition 17.12.1  - this is the one the AMD driver page gives me when I input the FX9830P APU

       

      As I said, I've made several attempts at installing the driver software, following the guide here: Laptop graphics update...How to . After the first attempt I've also been sure to make a clean install each time, as detailed here: Clean Install AMD Graphics Drivers . I do wonder if perhaps windows 10 installed something automatically during the first attempt which I was not aware of and did not remove when attempting a clean install, but if so I would not know where to find it (I used DDU to hopefully remove as much as possible, and also manually removed the C:\AMD folder each time). Whatever the case, each time I install the result is the same, both devices report the code 43 error, and if I attempt to open the Radeon Settings I recieve an error stating "Radeon Settings are currently not available.Please try again after connecting AMD graphics". Anything graphics-intensive runs at single-digit fps, so I assume that the graphics card is indeed not being used.

       

      I'm at a loss. I'm not a total newbie, but certainly not experienced enough to get any further with this on my own, any help would be hugely appreciated. Attached is a screenshot of the device manager page with the error visible in case I missed something you might find useful. Sorry if I've left out anything obvious, let me know and I'll get it for you.

       

      Thanks in advance.

       

       

      EDIT: After some sleep and some more forum searching it seemed as though the newest driver was causing problems for quite a number of people, so I clean-installed an older driver - crimson 16.9.2 - and (so far) this appears to have solved most of my problems. Both graphics devices are recognized and work without error, and applications run smoothly. The Radeon Settings program also works now. It's far from a perfect solution - some programs are not recognizing the RX 460 and will only use the integrated graphics, presumably due to the older driver - but it at least makes a huge improvement over where I was before. I'm not going to say it's "solved", but I at least have a workaround for now. If anybody else with the same problem wants to try this, though, make absolutely certain you prevent Windows Update from installing new graphics drivers using the guides on this forum, or it will quickly replace the older driver and the problem will return.