0 Replies Latest reply on Jan 13, 2018 4:00 PM by m3tho5

    Ubuntu 16.04.3 with RX 480 boots to sleeping monitor

    m3tho5

      I have an odd problem and I'm out of ideas.  I'm running the Strix RX 480 on Z9pe-d8, Ubuntu 16.04.3, kernels 4.10.0-28 to 4.10.0-42 (rolling hwe).  I've managed to get 17.40 and 17.50 amdgpu-pro drivers running but ONLY in kernel 4.10.0-28.  When I boot into the other kernels, the monitor just goes to sleep on boot; there's no login screen.  I read that since 17.30 is supposed to support kernel 4.10+.  I've tried various grub options (acpi=off, nonmemset, acpi_osi=Windows 2009, 2006 and Linux... etc.).

       

      Anyone out there have a similar issue or have a solution?

       

      UPDATE:

      So, I tried the 17.40 and 17.50 drivers with various 4.10.38 (40, 42 generic) and the Spectre/Meltdown fix 4.13 kernels to no avail. Errors on boot with 4.13 kernel attached. I decided I might as well try the mainline drivers, and finally got it to work with 17.50 + Ubuntu Kernel 4.14.13.  I guess there's something odd going on with Ubuntu.

       

      wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413_4.14.13-041413.201801101001_all.deb

      wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-headers-4.14.13-041413-generic_4.14.13-041413.201801101001_amd64.deb

      wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14.13/linux-image-4.14.13-041413-generic_4.14.13-041413.201801101001_amd64.deb

      sudo dpkg -i *.deb

       

      Message was edited by: Mike Wu

       

      Message was edited by: Mike Wu