0 Replies Latest reply on Dec 12, 2017 11:26 PM by bccrackdaddy

    AMD Radeon (TM) RX 480 No Longer Works with MST Hub after Latest Driver Update

    bccrackdaddy

      I have a windows 10 machine.  I have been running 6 monitors off of the AMD Radeon (TM) RX 480 no problem since March (Driver Version was dated 06/27/2017).  My setup was to run 3 monitors off one Display port via an 3 port MST Hub, 2 monitors off the remaining 2 Display Ports, and a 6th monitor from the HDMI Port.  On Dec 06, there looks like there was some AMD Update (new driver version: 23.20.788.0 11-02-17) and since then my MST Hub is not working properly.  When it is plugged in all the monitors attached to it are detected correctly in both Windows and the AMD Settings, however the screens are all black. (turned off).  I have tested each monitor plugged in separately into the Display Ports from the Radeon, and no issues.  I have tried the MST Hub in the Intel On Board Graphics and it works perfectly.    However the MST Hub is no longer working with the Radeon.  If I only plug in one monitor into the MST hub, it SOMETIMES works, however as soon as i add a 2nd or 3rd monitor, none of them work (blank screen, even though the monitors are detected).

       

      Currently I am using both my onboard intel graphics display port with the MST hub, and the other 4 monitors plugged directly into the radeon card, to achieve my 6 monitors, but this is not ideal, as my graphics are not very good with the onboard display, and Ideally the MST hub should continue to work with the Radeon.

       

      The MST Hub I have is a startech 3 port displayport hub.

       

      I have tried clean install and reinstall with no luck.

       

      Please Help!