AnsweredAssumed Answered

r7 250 gpu scaling not working?

Question asked by travadia on Dec 10, 2017
Latest reply on Jan 21, 2019 by alexvas

hello.

i am a bit confused.. i have games and i want to play them on different resolutions. but my problem is: the games are stretched in full screen and that looks silly.

so i wanted to make use of the gpu scaling/scaling options in amd (i have amd driver version 17.11.4)

on many threads i read that gpu scaling is solved in 17.11.2.. but somehow it isnt for me.

 

let me explain, there are 3 options for me: keeps aspect ration, full screen and centered (my driver and pc isnt english, so i tried to translate the 3 options i can choose in scaling menu)

what i did: turn on gpu sclaing and then pick "centered" in scaling.

then i tried to open a game: nothing happens. no sclaing. only full screen and ugly stretching.

next what i tried: i made a game profile for a game i wanted to start andit is possible to add scaling option to a single game profile, too. so i set up scaling to "centered" in game profile.

then opened game again: nothing hapens, just ugly stretching.

 

last thing i did: i changed my desktop resolution and surprise: sclaing worked. my desktop was 1600x900 centered. not strectehd. there were black bars filling the rest of the screen and my desktop was original, not-stretched 1600x900 now.

 

but my problem is: i dont want to change desktop resolution always, when i want to play a game with different resolution. back then i had a gforce gpu. and there was never a problem with scaling. my screen resolution was full hd, and when i opened a game with lower resolution, my gforce automatic changed my screen so i could play with centered, not-stretched game display. and when i turn off game, my resolution went back to full hd.

 

but AMD is buggy. it doesnt change ratio when i open game. its still stretched. it only changes centered ratio when i completele change my desktop resolution manually.

 

what can i do? should i uninstall AMD and amke a clean new install? is there a fix for this error?

 

greetings and thanks for reading.

Outcomes