AnsweredAssumed Answered

I need help installing drivers for a 7970m on my Alienware

Question asked by veliq on Dec 6, 2017
  • AMD Graphics Card
      • Radeon HD 7970m
  • Desktop or Laptop System
    • Alienware m17xR4
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • None for AMD - Integrated Intel HD4000
  • Display Devices
    • Laptop LCD display
  • Motherboard + Bios Revision
    • Alienware M17xR4 (U3E1) Bios Version A12
  • CPU/APU
    • Intel Core i7 3720QM @ 2.60GHz - Ivy Bridge 22nm Technology
  • Power Supply Unit  Make, Model & Wattage
    • Unknown
  • RAM
    • 16.0GB Dual-Channel DDR3 @ 798MHz (11-11-11-28)

Describe your issue:

  • Around 2 years ago I started having problems with my 7970 and ended up removing it from my laptop with the belief it was dead, per the buzz at the time in this forums I checked.  I never heard any beeping sounds or anything, just couldn't get it functioning, I no longer remember the details.  I recently purchased a new 7970 pulled from unsold new dell laptops, seated it appropriately, and have been unable to get drivers installed.  The card reads fine per GPU-Z and Speccy, and is detected and listed in BIOS as ATI GFX
  • The process hangs, sending the cursor to the middle of the screen, and eventually going to a black screen with no apparent response from any actions on my part or active processing occurring.  This happens if I allow WU to attempt to auto-update, which I have since disabled through deleting the AMD folder and the device settings.  When rebooting eventually occurs (I believe always due to my holding the power button, even when running while I went to work) I can enter safe mode to uninstall the drivers, which appear to have successfully installed, but load to a black (backlit) and apparently non-responsive screen.
  • I turned off Windows Defender via Registry, it's a clean install of Windows 10.
  • I've attempted to install various iterations, each time uninstalling the AMD and Intel drivers using DDU, including
    • Most recent Leshcat - Catalyst_16.2.1_UnifL_v1.0
    • Most recent Relive - non-whql-win10-64bit-radeon-software-crimson-relive-17.11.4-nov27
    • Two versions of the Catalyst - amd-catalyst-15.11.1beta-64bit-win10-win8.1-win7-nov14 & whql-win10-catalyst-15.7.1-oct30
    • Original drivers from Dell - Video_Driver_4NYM5_WN_9.003_A00
    • Along with a couple older variants - VGA_AMD_13.201.0.0_W81x64_A
  • I've received a BSOD when attempting to install some of these, mostly the 'Thread_stuck_in_device_driver', although when attempting Cat 15.11 it was 'Machine_check_exception'.

 

I honestly wonder if my original card may not have been dead after all, and I just gave up on it a bit too soon. 

 

I thank any and all that are able to assist here, and hope to leave a trail for others to succeed.

Outcomes