0 Replies Latest reply on Dec 7, 2017 5:47 AM by furiousgeorge

    Has IOMMU/GPU Passthrough been fixed with TR AGESA 1.0.0.4?

    furiousgeorge

      I have a Zenith Extreme, and like most everyone else, I get a D3 hang when I try to start a VM with an attached GPU.

       

      My understanding is that IOMMU, like with Ryzen, needs to be fixed by an AGESA update.  My board, a Zenith Extreme, has a beta bios which was released only a few days ago, but it only has microcode 0x8001129, which I assume is part of 1.0.0.3.  I know that some boards are already running 1.0.0.4, but  I have not heard reports of passthrough being fixed.  That makes me concerned that it hasn't been.

       

      I know AMD has a survey out, which I've completed.  While it shows someone cares, it's also been out for months, and so I'm starting to get concerned in the context of the above that the problem will not be fixed for many more months, or perhaps not at all.

       

      The reddit thread which seems to have the only official statements on the matter from AMD that I can find (such as they are) has died.  The AMD rep who promised to follow up disappeared with the thread, never posting again.

       

      https://www.reddit.com/r/Amd/comments/6vbe6w/threadripper_broken_on_linux_for_pci_passthrough/

       

      Has the official position be updated since then?  If 1.0.0.4 does not fix the issue, will 1.0.0.5 definitely fix it?  Any info is appreciated.

       

      Thanks for reading.