3 Replies Latest reply on Dec 4, 2017 8:57 AM by daquteness

    1603 general error

    aghalke92

      What kind of error Is this?? Please help

        • Re: 1603 general error
          faqu

          Try to uninstall the driver , restart the PC , and then attempt to install the driver again.

          If this isn't working , then try to uninstall the driver using DDU (Display Driver Uninstaller) in safe mode , and then attempt to install the driver again.

          • Re: 1603 general error
            daquteness

            This error is probably one of the best documented and frustrating cases in this forum, I would strongly suggest you give it a search to complement the list below of steps to try:

             

            Use latest version of DDU in safe mode and try to reinstall;

            Try reverting Windows to a slightly earlier date if you have a restore point, to when it last worked;

            You need to block all drivers update settings and policies, try following these steps: How to Prevent Windows from Automatically Updating Specific Drivers

            Try re-installing with the network unplugged;

            If all else fails, open up a support ticket with AMD but I'm pretty sure you're going to go through some of the same steps as above.

             

            I had that issue before and last evening Windows decided to be a good boy and silently downloaded and installed FCU - which instantly borked the driver installer - both cases I ended up re-installing Windows. I would suggest you install a non-FCU windows, install AMD drivers, put the policies described in that link in place, and it should help future-proof it, but I've tried everything and so have MANY others, and only a few people actually got to fix it somehow.

             

            Sorry to be the bearer of potentially bad news, you can also ask for more help in AMDRT Discord (see left side of Red Team Community home page for link).

             

            Cheers!

            V.

            • Re: 1603 general error
              ray_m

              Please provide the essential INFORMATION REQUIRED WHEN POSTING A QUESTION  with your question.

               

              Also refer to the troubleshooting steps listed here : Error 1603 – A General Error Has Occurred During the Installation of the AMD Software Package

              1 of 1 people found this helpful