4 Replies Latest reply on Dec 15, 2017 2:12 PM by alexdevoratorul

    SAPPHIRE R9 290 Tri-X OC black screen issues since last week

    alexdevoratorul

      Hello! I have an SAPPHIRE R9 290 Tri-X OC and i use Windows 10 updated to latest available version. Since last week, i get black screens while i am gaming or even in desktop mode (not so often). I updated to latest drivers, mb bios, etc. and i still get the black screen issue. Have you encountered something similar? I heard it could be from a windows update incompatiblity?! Mention that i ran test including furmark and intel burn test..absolutely everything works perfectly. When i get black screen issue, i can still hear sound for few more seconds. Now i installed an gpu driver from july 2017, and still testing. Any ideas for solving this problem? Thank you!

        • Re: SAPPHIRE R9 290 Tri-X OC black screen issues since last week
          goodplay

          Have you looked through "windows reliability history" report, "msinfo" errors, "dxdiag" errors, "perfmon" report.

          Dedicated OS forums (e.g. tenforums.com) can help with any OS problems.

          Also please supply INFORMATION REQUIRED WHEN POSTING A QUESTION for someone to offer further suggestions.

          • Re: SAPPHIRE R9 290 Tri-X OC black screen issues since last week
            wpan2002

            Have you tried uninstalling the current drivers and installing the latest one on the AMD website?

            While your at it... make sure to clean out the dust bunnies and a reapplication of thermal compound maybe nice. (From my experience don't use MX-4 since it doesn't last so long till it dries up)

            • Re: SAPPHIRE R9 290 Tri-X OC black screen issues since last week
              alexdevoratorul
              • AMD Graphics Card: Sapphire R9 290 Tri-X OC 4gb with VBIOS ver. 015.044.000.011.000000
              • Operating System: Windows 10 64bit
              • Driver version installed: Radeon Software Crimson Edition 17.11.1 (had latest and still the same problem)
              • Display Devices: LG 24GM77 running in 1920x1080 120hz
              • Motherboard: MSI H97 Pc Mate updated to latest bios (after problem): 7850v5.9
              • CPU/APU: Intel 4690 with Cooler Master Hyper 212Evo
              • Power Supply:Seasonic S12II-620 Bronze 620w
              • RAM: Corsair Vengeance 1600mhz 2x4Gb

               

              I updated all my drivers, reinstalled Windows, blow the dust off the pc, and i still encounter this problem. When i bought the R9 290, almost 3 years ago i had similar black screen issues in idle only and upgraded to the actual vbios and everything was absolutely fine until now. Sapphire tech support told me this is the latest vbios available for my Gpu.

              I ran stresstest for memory, gpu and cpu and everything works fine.

              In windows log event i get only errors related to forced shutdown (ex LiveKernelEventCode 141) that i apply after black screen...so just the "symptom" not the "cause".

              I suspect this started after windows updates since a week ago. It appears randomly after 5 min, an hour...it does not matter.

              Thank you for support until now, hope to solve this annoying thing.

              I now test the "force constant voltage" in MSI Afterburner, after i read it in a forum with r9 390 with same issues

               

              Edit: still got Black screen with forced constant voltage

              Later edit: last 2 days were better, i managed to play around 1.5 hours straight with no issues. Still don't know what was the issue or if it is still there.

              • Re: SAPPHIRE R9 290 Tri-X OC black screen issues since last week
                alexdevoratorul

                It was a power issue. Replaced PSU with a new one and everything work as new.