3 Replies Latest reply on Nov 30, 2017 8:03 AM by mtpatrick

    RX 580 Stopped working within 24 hours

    guineapirate

      I just received a PowerColor RX 580 8GB yesterday. I installed it and it was working yesterday, granted, not particularly well.  The screen would go black during any kind of benchmark testing and games would crash fairly often at first.  Then it seemed to stabilize and I was able to play games for the rest of the evening.  This morning when I went to turn on my PC, the video wasn't working.  I plugged in the onboard graphics and took a look in my motherboard's (ASUS Maximus VII Hero) bios and it wasn't recognizing the card at all.  I tried plugging in my old GTX 770, and it worked just fine, but even after putting the RX 580 back in, it still didn't work.  I have tried using DDU to uninstall both the AMD and GTX drivers, swapping out the PCIe power cable, pretty much anything I could think of or find online and nothing worked.  One strange thing, when I plug the card into the 2nd PCIe slot, which is x8, it recognizes the card, but it can't run from that slot, but in the first slot, my motherboard says there's nothing plugged in.  Does anyone have any idea what could be going on?

        • Re: RX 580 Stopped working within 24 hours
          mtpatrick

          Bump for visibility. I have these exact symptoms as well. I cant tell you how many times i have nuked the windows installation and re-loaded different driver versions. Still the same issue.

            • Re: RX 580 Stopped working within 24 hours
              mtpatrick

              In my situation, my computer does not post if power is given to the GPU and video is being displayed through the GPU. When i switched the video output to the VGA on my mother board via the bios, i was able to get the card to boot (without power to GPU). Should i connect power to the gpu after, device manager will recognize the card, but upon try to install the card drivers it keeps crashing the machine. It appears the RX580 vBios were corrupted after a recent windows update that was ran on my machine prior to all of this. After calling a support line for my GPU manufacture the tech advised to process an RMA. Ill update when i receive my new card..

            • Re: RX 580 Stopped working within 24 hours
              blazek

              Seems to be a defective card, have you contacted PowerColor for an RMA?

              1 of 1 people found this helpful