AnsweredAssumed Answered

RX 580 Stopped working within 24 hours

Question asked by guineapirate on Nov 28, 2017
Latest reply on Nov 30, 2017 by mtpatrick

I just received a PowerColor RX 580 8GB yesterday. I installed it and it was working yesterday, granted, not particularly well.  The screen would go black during any kind of benchmark testing and games would crash fairly often at first.  Then it seemed to stabilize and I was able to play games for the rest of the evening.  This morning when I went to turn on my PC, the video wasn't working.  I plugged in the onboard graphics and took a look in my motherboard's (ASUS Maximus VII Hero) bios and it wasn't recognizing the card at all.  I tried plugging in my old GTX 770, and it worked just fine, but even after putting the RX 580 back in, it still didn't work.  I have tried using DDU to uninstall both the AMD and GTX drivers, swapping out the PCIe power cable, pretty much anything I could think of or find online and nothing worked.  One strange thing, when I plug the card into the 2nd PCIe slot, which is x8, it recognizes the card, but it can't run from that slot, but in the first slot, my motherboard says there's nothing plugged in.  Does anyone have any idea what could be going on?

Outcomes