bmbachman

Beginning OpenCL Developer with APP SDK Installation Issue

Discussion created by bmbachman on Nov 24, 2017
Latest reply on Nov 30, 2017 by bmbachman

Hi everyone.  I just started working with OpenCL a few weeks ago using pyopencl on a laptop at work with an Intel CPU and Nvidia GPU, and am now trying to get to work on my home machine with an AMD FX 8150 CPU and two HD6950 GPUs.  I have installed version 3.0 of the APP SDK and the latest drivers available for the GPUs.  Additional system details are below:

 

Windows 10 64-bit

Radeon Software Version: 16.2.1

Radeon Software Edition: Crimson

Radeon Settings Version: 2016.0226.1531.27895

Driver Packaging Version: 15.301.1901-160226a-318062E

OpenCL™ Version: 2.0.4.0

 

 

The main issue I am having is that when I try to run the samples, such as Mandelbrot.exe, I get a the following messages which indicate that the GPUs are not detected:

 

Platform 0: Intel(R) Corporation

Platform 1: Advanced Micro Devices, Inc.

GPU not found. Falling back to CPU device

Platform found: Advanced Micro Devices, Inc.

Selected Platform Vendor: Advanced Micro Devices, Inc.

Device 0: AMD FX(tm)-8150 Eight-Core Processor     ....etc

 

The sample runs, but after completely uninstalling the APP SDK and display drivers, and then reinstalling the SDK first then display drivers, the GPUs are still not detected.

 

I suspect this is also why I cannot import pyopencl without getting the error below.  After installing the Intel OpenCL SDK and drivers, I was able to import the package, but but the GPUs were still not listed as devices under the AMD platform.  I have since uninstalled the Intel SDK and drivers, and reinstalled the APP SDK and display drivers.  Is OpenCL just not supported on these GPUs anymore?  Would an older version of the SDK work?  I understand these GPUs are somewhat old and I am running beta drivers that are not supported anymore, so maybe there isn't a good solution.  But I'd really appreciate any help getting this set up so I can get my feet wet learning OpenCL with the hardware I already have if possible.

 

Thank you!

 

pyopenCL error:

 

Python 3.6.3 |Anaconda custom (64-bit)| (default, Oct 15 2017, 03:27:45) [MSC v.1900 64 bit (AMD64)]

Type "copyright", "credits" or "license" for more information.

 

IPython 6.1.0 -- An enhanced Interactive Python.

Traceback (most recent call last):

 

  File "<ipython-input-1-d80ce023813b>", line 1, in <module>

    runfile('G:/pyopenclScripts/test1.py', wdir='G:/pyopenclScripts')

 

  File "G:\Anaconda3\lib\site-packages\spyder\utils\site\sitecustomize.py", line 710, in runfile

    execfile(filename, namespace)

 

  File "G:\Anaconda3\lib\site-packages\spyder\utils\site\sitecustomize.py", line 101, in execfile

    exec(compile(f.read(), filename, 'exec'), namespace)

 

  File "G:/pyopenclScripts/test1.py", line 8, in <module>

    import pyopencl as cl

 

  File "G:\Anaconda3\lib\site-packages\pyopencl\__init__.py", line 37, in <module>

    import pyopencl.cffi_cl as _cl

 

  File "G:\Anaconda3\lib\site-packages\pyopencl\cffi_cl.py", line 39, in <module>

    from pyopencl._cffi import ffi as _ffi

 

ImportError: DLL load failed: The specified procedure could not be found.

Outcomes