AnsweredAssumed Answered

Vega 64 on Ubuntu 16.04.3, no opencl, clinfo error: terminate called after throwing an instance of 'cl::Error'

Question asked by walsch on Nov 24, 2017
Latest reply on Mar 19, 2018 by walsch

Hello,

 

so I got a new Vega 64 and the new graphic cards works for outputting to a tft monitor, but I can get no opencl running.

 

Before I used a RX 580 which was working fine in exactly the same pc. When I plug back the RX 580 instead of the VEGA 64 the RX 580 works fine and I do get opencl.

 

I tried reinstalling the amdgpu-pro 17.4 drivers several times without success, naturally I also tried restarting alot of times. PC is a ubuntu 16.04.3 fresh install.

 

I am out of my depth now, so I am asking for help. I attached a lot of diag and logfiles.

 

The error message that I am getting from clinfo is:

 

env LLVM_BIN=/opt/amdgpu-pro/bin /opt/amdgpu-pro/bin/clinfo

 

terminate called after throwing an instance of 'cl::Error'

  what():  clGetPlatformIDs

 

Could somebody please have a look at this ?

 

BR

W

Outcomes