3 Replies Latest reply on Nov 27, 2017 8:14 AM by amdmatt

    WOLFENSTEIN 2 don't run on Windows 8.1

    thunder97shock

      Hi everybody, today i downloaded the demo version of wolfenstein 2, but there is a problem, when i start the game i get an error message in wich it's written that require the 17.10.2. I tried if there were updates for my r9 390 but nothing, in this moment there are only the 17.7.1. I have windows 8.1 64bit. Why dont they update?