1 Reply Latest reply on Nov 25, 2017 8:24 AM by riven_cole

    hdmi monitor connected through home theater receiver defaulting to 29hz interlaced

    riven_cole

      ok i have seen similar issues but none quite the same, so here we go again.

      to start my secondary displays cables are hdmi 2.0, and my primary is 1.4 (also tried using a dvi to hdmi cable and had the same problem regardless) and my displays are set to 1080p in extended display mode.

      i have an rx 480 and windows 10. every single time i boot my computer my primary monitor (samsung s22f350 pc monitor), which is 60hz sets itself to 59hz and my secondary monitor (lg 22ln4510 tv with hdmi port set to pc mode. setting it to standard makes no difference in the bug), also an actual 60hz panel, which is connected through a home theater receiver (onkyo tx-sr333 if it matters) sets itself to 1080i 29hz interlaced according to the display itself. now, if i manually set both displays to 60hz they work fine (with noticeable picture quality improvement) but every time i restart... bam back to 59 on primary and 29hz on secondary.

      if i disconnect the receiver than connect both displays to the card, they work without issue except they both go to 59hz (which i have read is a windows bug). why i believe this to be an amd issue is cause my last card (r9 280) didnt do this and my current spare (gtx 960) doesnt do this, nor does the integrated graphics on my i5-7500. only the rx 480 has this issue when connected to the receiver.

      i do not have any way to hook the receiver up without hdmi since my mobo doesnt have toslink/spdif and the receiver will not play audio through hdmi without a display attached to the hdmi out.

      i also have the receiver set for use with a pc and i do not think it is directly related to the problem other than the card not being able to properly talk to it, since it does not do any video processing i think.

      i do not know if it is the current drivers (17.11.2 as of this post) cause i havent tried earlier ones yet.

      does anyone actually know the cause and/or fix for this bug?

       

      thanks for reading the wall of text