AnsweredAssumed Answered

AMDGPU-PRO 17.40 on a Ubuntu 16.04 Docker image

Question asked by loic-yvonnet on Nov 19, 2017
Latest reply on Nov 20, 2017 by loic-yvonnet

I need to run a 3D simulation inside a Docker image. This Docker image is built on top of Ubuntu 16.04.

 

My host machine runs also Ubuntu 16.04 and I have installed the AMDGPU-PRO 17.40 drivers for my AMD FirePro w7100 graphic card by following this tutorial. On my host, the driver installation works fine and I can run my 3D simulation.

 

I tried to run the driver installation from the following Dockerfile:

FROM ubuntu:16.04

# https://www2.ati.com/drivers/linux/ubuntu/amdgpu-pro-17.40-492261.tar.xz
ADD amdgpu-pro-17.40-492261.tar.xz /tmp

RUN \
  apt-get update && \
  apt-get -y upgrade && \
  cd /tmp/amdgpu-pro-17.40-492261 && \
  ./amdgpu-pro-install

CMD ["bash"]

 

The Docker image creation is issued as follows:

docker build -t ubuntu_amdgpu .

The driver installation process fails during the Docker image build with the following error messages:

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

 

The following packages have unmet dependencies:

amdgpu-pro-lib32 : Depends: libdrm-amdgpu-pro-amdgpu1:i386 (= 1:2.4.82-492261)

                    Depends: libgbm1-amdgpu-pro:i386 (= 17.40-492261)

                    Depends: libgl1-amdgpu-pro-glx:i386 (= 17.40-492261)

                    Depends: libgl1-amdgpu-pro-dri:i386 (= 17.40-492261)

                    Depends: libegl1-amdgpu-pro:i386 (= 17.40-492261)

                    Depends: libgles2-amdgpu-pro:i386 (= 17.40-492261)

                    Depends: vulkan-amdgpu-pro:i386 (= 17.40-492261)

                    Depends: libvdpau-amdgpu-pro:i386 (= 1:17.0.1-492261)

                    Depends: libopencl1-amdgpu-pro:i386 (= 17.40-492261)

                    Depends: opencl-amdgpu-pro-icd:i386 (= 17.40-492261)

E: Unable to correct problems, you have held broken packages.

How may I resolve these unmet dependencies?

Outcomes