10 Replies Latest reply on Nov 14, 2017 6:56 PM by mhimmel95

    Crimson/Drivers Not Working

    mhimmel95

      I've got a problem with my HP Pavilion 15z. The processor is an AMD Quad-Core A10-8700p Processor running Windows 10-64, it has an integrated R6 and a dedicated AMD Radeon R7 M360 Discrete 2Gb. Purchased this 11/4/15. I've been using it for Fallout 4, New Vegas, Skyrim, etc and it has always worked fine. About a month ago, I decided to do a factory reset because I had a whole bunch of junk on it. I decided to get the AMD program to mess with the function of the switchable graphics and try to optimize it. Unfortunately, when I downloaded Crimson it said that there were no AMD drivers detected. I tried the auto-detect to get the right ones, but it did the same thing. I figured it was just a bug so i removed the AMD program.

       

      I tried to run the PC without it, but the normal drivers wouldn't work like before the reset; no game works. Eventually I went back, found an old version of Catalyst and used it for a few weeks and it worked fine, but last night a boot file on my hard drive corrupted, so I had to factory reset again. I've got everything back the way it was and now Skyrim takes about 8 minutes to load and I get about 10 frames per minute (yeah, minute). On top of that, my DxDiag says my processor is the R7 M360 (the correct one), but my device list on Windows says it is a R8 M365dx. If I remove the driver and let Windows auto-detect the GPU it find the correct one, but then downloads the incorrect driver. I have no clue where to go from here because just making Windows go to High Performance mode isn't making anything any better. Not sure what I need to attach to this, but let me know and I will add it.

       

      Also, I tried to download the correct, GPU specific driver from AMD but it detects the wrong GPU (the R8 instead of the R7) and doesn't work.

       

      Thanks!