AnsweredAssumed Answered

code 31, VGAsave, Beer and heartbreak

Question asked by unknowndobo on Nov 11, 2017

Hi folks,
So I’ve recently rejoined the community of desktop owners, I had a gaming rig before but Farcry 1 was the benchmark game of the day so that gives you some indication of how long ago that was, after many a year with just my laptop.  With me no longer requiring a gaming pc, just one that can play films, music, allow me to write long winded poems about mongoose and occasionally video capture I figured that building a Frankenstein’s monster machine out of components was the best option. It didn't need to run amazingly well after all and i couldn't afford to do much more than that.

I'd be lying if i were to say it's not been a struggle, between being sent the wrong ram, my bluray drive not working, my internet constantly losing connection, the weird smell of cheese coming from my case and my graphics card not working, I'm starting to wish I'd let someone else build this.

Whilst I’ve managed to nail down and fix many of the issues I've come across so far by researching online the graphics card is still giving me issues and I’m at the point where even with my blackbelt in googlefu I’m not being able to find a solution.

So here are some basic bits of info before i start.

Graphics : AMD Radeon HD 7700 Series (XFX R7700)
  ATI Radeon HD  3200 graphics (on Board)
Desktop or Laptop System: Desktop
Operating System : windows 7 64bit
Driver version installed : 22.19.662.4
Display Devices: Sony  SDM-HS73, Displayport to VGA adapter, 1280x1024
Motherboard + Bios Revision: 
Acer RS780HVF Bios Version American megatrends R01-B4
CPU/APU:
AMD Phenom2 x4 805 2.5ghz
Power Supply Unit : FSP Group Inc
FSP455-60PAF Server - Power Supply, 400w
RAM: 4gb

Physical: Dark skinned and piercing blue fans
Interests: Enjoys looking at pictures of people walking on the beach


So the HD7700 card is new and it's fighting me.  After a long winded slog to get the drivers to work I’m still no closer to being able to use it and i can't seem to see why.

Currently in device manager i have a code 31 error message on the HD 7700 card and i seem to have exhausted many of the options to try to get it to work..

Things I've tried so far:

Rebooting,

Uninstalling and reinstalling drivers,

Uninstalling and re-downloading drivers from another source,

Hard uninstalling using AMD clean uninstall utility (this removed the drivers for the on board card as well and I reinstalled both),
Checking card compatibility with windows 7

Deleting the upperfilter and lowerfilter values for the card in the registry files.
Drinking all the beer and passing out on the floor, hoping it will fix itself.

So far no luck.

Then i read on a forum that i might be able to tweak the settings so it works using the RadeonSettings program and that's when i really started to fall down the rabbit hole.  You see when i try to use radeon settings i get two new errors.

one: Radeon Settings currently not available please try again after connecting AMD graphics.
And two: Failed to create opengl context for format qyadayadayada version 2.0. Install a driver providing opengl 2.0 or higher....etcetc


So it looks like for some reason I’ve not got a new version of opengl, weird as my new card is meant to be running opengl 4.5 with its drivers according to wikipedia.
So i looked into how to update opengl and hit my roadblock.

The tutorial I followed said that i needed to go into screen resolution, advanced settings, adapter type, properties and tell it to update from there.  The problem is that nothing is filled in under adapter type or adapter information.
under adapter information it says chip type <unavailable>, DAC type <unavailable>, adapter string <unavailable>, bios information <unavailable>, total available graphics memory <unavailable> and the last three pieces of information all say n/a . When i click on properties it comes up with VgaSave properties instead of the actual graphics card and because it's a default device name there is no option to update the drivers.

So i have Vgasave in my display adapter settings but my hd7700 in device manager....and never the two shall meet.

Have i missed something really basic? i feel like I’ve been trying to cover all of the options as i go but I’m not computer savvy enough to know if I missed something.


Many thanks

Unknown Dobo

Outcomes