AnsweredAssumed Answered

BSoDs and RSoDs - RX 580

Question asked by eibe on Nov 9, 2017
Latest reply on Nov 10, 2017 by elstaci

Hello,

  

the relationship between my RX 580 and me got complicated since late September. And I am growing tired of this problem since it has been haunting me for more than a month.

  

The problem

I have occasionally experienced BSoDs (error: THREAD_STUCK_IN_DEVICE_DRIVER) when launching games, and RSoDs (these without any sort of text) when playing games (RSoDs are much rarer than BSoDs).

When reading the minidump files the BSoDs error always leads to atikmdag.sys (ATI driver). I have found no way to find the cause of RSoDs.

  

What I tried doing

So far I have tried multiple fixes, none of which worked. I have tried to:

  • Update the GPU drivers (every time first cleaning the old ones with DDU while running the PC in Safe Mode).
  • Re-install Windows 10 (64-bit, Enterprise) after being prompted to do so by Sapphire Support
  • Update the chipset drivers
  • Check the RAM and GPU for being seated properly
  • Run Uningine Valley Benchmark, Memtest64

  

My system

- Ryzen 5 1600 @ 3.2GHz (stock) (turboes all cores to 3.4GHz or 1/2 to 3.6GHz)

- Biostar X370GTN (Mini-ITX) - 1.0.0.4 AGESA BIOS

- G.Skill Trident Z 16GB @ 3200, 14cl

- Sapphire Pulse RX 580 @ 1366MHz (stock), stock voltage, connected with 6+2 cable

- Corsair SF450 - 450 watts, modular

- Crucial MX300 525GB (only storage, contains both the OS and all the other files)

- Corsair SP120 fan

- Node 202 case

- NOTHING OVERHEATS

  

I am in desperate need of tips to fix this issue. I have now re-contacted Sapphire, but I would like to avoid going through the hassle of RMA. Especially considering that I have read several times on other forums that replacing the card did NOT fix their issues. Could it be the motherboard?

Outcomes