AnsweredAssumed Answered

Corel Home & Student X7 with AMD 17.11.1 - hangs after start screen (any document, any method of opening))

Question asked by chaosdruid on Nov 6, 2017
Latest reply on Mar 23, 2018 by chaosdruid

CURRENT WORKAROUND: AMD 17.9.3   (22.19.677.257) http://support.amd.com/en-us/download/desktop/previous?os=Windows%2010%20-%2064

 

Corel H&S X7 (with all updates)

Windows 10 64bit

AMD drivers 17.11.1 on ->18.2.2

 

3x monitors

 

Installed 17.11.1 - no issues until today when I tried to use CorelDRAW H&S X7

 

App opens to the start screen, but is a little slow

Any attempt to open a document, or start a new one FAILS

CorelDRAW hangs, mouse goes stuttery, and a cpl seconds later the whole system is nerfed.

Mouse stutters, responds at about 2 fps with severe lag and delay on action, all actions (page reloads, clicking any other app, clicking an app to start, opening taskmanger etc. literally everything)

After a minute I can close CD

 

Sometimes apps respond badly if they were opened last in Eyefinity mode, then opened next in standard mode (Eyefinity OFF)

I put the system into Eyefininty mode, and it opened a new document after 20 seconds (with the stuttering)

Closed Corel, left in eyefinity, opened again - started quickly as if fixed.

Checked all dockers/toolbars to make sure they were docked

Turned off Eyefinity

CorelD back to not working with same results as previously

Eyefinity on - works but slow to start ... weird

 

Used F8 to reset CorelDRAW - nothing fixed

Did a "Repair" from Corel uninstall option - nothing fixed

 

Rolled back driver to 17.0.1

 

Everything working fine.

 

Message was edited by: Alex D - clarify what app F8 and Repair were performed on

 

Update 2018-Jan-07 :

 

I kept trying the new updates, latest were 17.12.1 and 17.12.2.

Still do not work with Coreldraw.

 

I rolled back every time, but kept progressing from 17.0.1 until I found the latest one that worked OK (17.9.3)

There is a small 1 to 2 second delay [creating a new document/opening from file menu/opening a "recent" document], but it is hardly noticeable

 

I have put the tested version at the top so ppl can see which currently work for me.

 

Update 2018-Jan:

After initial contact with Corel, I was advised that the only issue was that Corel X7 is "not designed for Windows 10"

After much to- and fro-ing of emails, over a week, I was told that i should "downgrade to Windows 8"

By that time the 30 days was up. Also gone were the 28 Amazon days.

 

It just meant a work around for the printing probem, and it was a minor inconvenience.

Things got worse and worse, until now we are left with me having done:

a full set of tests

uninstalling X7 4 times

Resetting everything.

Reinstalling graphics drivers.

Doing the tests above

 

 

Update 2018-Feb:

uninstalled graphics drivers -> install EVERY version of the drivers since 17.01

uninstall them -> install the next one (clean install)

send dx reports and run software requested of me.

 

Sent in a report of how long each one took to open a new document, open a saved document

(both in Eyefinity mode, AND normal mode)

 

Problem persists through all driver versions to the one currently posted at the top of this page.

In Eyefinity mode, it takes around 8 seconds to open a new/saved document A4 300 dpi

Out of Eyefinity mode (as I call it "normal mode") to create/open a document of the same size:

From 2 minutes and 20 seconds up to 2 minutes and 45 seconds 2:20 - 2:40

 

Still I am told "Buy X8" or "downgrade your OS" - "it was not designed for Windows 10"

Unfortunately, the page I bought it from said Windows 7 / Windows 8 / Windows 10 !

 

Message was edited by: Alex D = add new testing updates at bottom of page

Outcomes