dan_e_boy

Help with problem installing crimson 17.11.1 invoked by BSOD Thread_stuck_in_device_driver

Discussion created by dan_e_boy on Nov 5, 2017
Latest reply on May 8, 2018 by dan_e_boy

Hi, I am new to this forum so I hope I will have enough details in this message.  Here are my system specs:

 

Win 10 home Version 10.0.16299 Build 16299 64 bit

Processor AMD A10-7860K Radeon R7, 12 Compute Cores 4C+8G, 3600 Mhz, 2 Core(s), 4 Logical Processor(s)

Stock heatsink (with the upgraded cooling solution), stock speed

2 x 4Gb Gskill ram set to 21?? MHz speed in bios (dual channel)

Asus mobo A68HM-PLUS, latest bios

WD hard drive

Using APU graphics R7

Windows fully current and updated

Crimson version 17.7 but I'm not confident in this( you'll see later if you read on)

So here is my problem.  I would very occasionally get a BSOD with the message of Thread_stuck_in_device_driver while playing World Of Warships.  I don't game a lot but my kids play some other games and to my knowledge it has only happen a few times on Roblox.  Every time this happened, I would check for crimson updates, install them, then it would seem like it worked fine again.  Then inevitably, it would happen again, and I would repeat.  This time when I got the BSOD I thought I should look up more info to see if there is a better solution.  I was at version 17.7.2 of crimson and noticed that there was a newer version 17.11.1 available.  Instead of using the update feature in the crimson software, I looked on Google which led me to this forum.  Here I found all sorts of advice about making sure that the old version of crimson should be totally removed before updating to 17.11.1.  So I followed the advice that the AMD website and forum users had about uninstalling, then run AMD cleanup, then run DDU in safe mode, set windows to not automatically install drivers, then install 17.11.1 with all antivirus and other apps turned off.  It did not work and I got the error message 182, cannot identify hardware.  Since then, I have tried many combinations of uninstall, reinstall with version 17.11.1 and previous version 17.7.2 and they all fail and give the same error message 182.  I even once got error message 1603 but it was 4 am and I can't remember what I did to get that one.  Finally I did a system restore to the last point that I had available which put crimson at version 17.7 from the windows update service.  I know from the time stamp on the restore point that it was during the time I was having problems so I am not confident that this version is installed correctly, though for now in non game applications I have not had a problem.  Haven't tried gaming yet.  Only time will tell if this version is stable on my system.

Outcomes