AnsweredAssumed Answered

[SOLVED] Linux 17.40 driver error: openGL GLX extension not supported by display

Question asked by sebadamus on Nov 5, 2017
Latest reply on Jan 5, 2018 by sebadamus

Hi,

 

I am trying to get to work  amdgpu-pro driver 17.30 on Linuxmint 18.2 (already know that the installation script have to be modified so it bypass the "ubuntu" string check, so it recognizes "linuxmint" string to let it install)

After installing it, it gives the subject error about "openGL GLX extension not supported by display" every time you try to run Steam software (it works with default opensource radeon driver)

I already post a thread in Linuxmint forums, but this have more to do with AMD driver installation, maybe I cant get some help here.

AMD 17.40 OpenGl GLX extension not supported by display - Linux Mint Forums

 

Here I post the details hoping to get it work on linux...

 

Its a Spahhire Nitro R9 390 8gb, it works good with default Xserver-xorg-video-radeon installed.  Installed the steam and play some games like Alien, this one says that my driver is not fully supported but it works anyway, so...

I decided to test last amdgpu-pro-17.40-492261 following instructions from https://forums.linuxmint.com/viewtopic.php?f=59&t=248059 and AMD ones http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx (and installed the Optional ROCm Component)

Everything installed righty... I think.  And removed the default Xserver-xorg-video-radeon as told in the forum thread.

Reboot OK, no problem as far.

I opened Steam again and I get a "OpenGl GLX extension not supported by display" so, no way to play Steam games for now.  Seems OpenGL GLX extensions are not loaded or something :-/

Can you give me some light? I search the forums but could not get to a solution or right hint.

 

Thanks!

 

Here more info about my installation:

 

glxinfo

name of display: :0

Error: couldn't find RGB GLX visual or fbconfig

 

inxi -Fz

System:    Host: mintmate Kernel: 4.13.0-16-generic x86_64 (64 bit) Desktop: MATE 1.18.0

           Distro: Linux Mint 18.2 Sonya

Machine:   Mobo: ASUSTeK model: M5A99X EVO R2.0 v: Rev 1.xx Bios: American Megatrends v: 2501 date: 04/03/2014

CPU:       Octa core AMD FX-8370 Eight-Core (-MCP-) cache: 16384 KB

           clock speeds: max: 4000 MHz 1: 4013 MHz 2: 4013 MHz 3: 4013 MHz 4: 4013 MHz 5: 4013 MHz 6: 4013 MHz

           7: 4013 MHz 8: 4013 MHz

Graphics:  Card: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290]

           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1920x1080@60.00hz

           GLX Renderer: N/A GLX Version: N/A

Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Hawaii HDMI Audio driver: snd_hda_intel

           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel

           Sound: Advanced Linux Sound Architecture v: k4.13.0-16-generic

Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169

           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>

Drives:    HDD Total Size: 4120.8GB (45.1% used) ID-1: /dev/sda model: WDC_WD4003FZEX size: 4000.8GB

           ID-2: /dev/sdb model: KINGSTON_SHSS37A size: 120.0GB

Partition: ID-1: / size: 42G used: 12G (31%) fs: ext4 dev: /dev/sdb5

           ID-2: swap-1 size: 12.12GB used: 0.00GB (0%) fs: swap dev: /dev/sdb6

RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors:   System Temperatures: cpu: 15.9C mobo: N/A gpu: 46.0

           Fan Speeds (in rpm): cpu: 0

Info:      Processes: 213 Uptime: 8 min Memory: 1030.7/15942.0MB Client: Shell (bash) inxi: 2.2.35

 

uname -a

Linux mintmate 4.13.0-16-generic #19~16.04.3-Ubuntu SMP Mon Oct 16 18:59:33 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

(Also tried 4.10 just in case)

 

lshw -C video

*-display            

       descripción: VGA compatible controller

       producto: Hawaii PRO [Radeon R9 290]

       fabricante: Advanced Micro Devices, Inc. [AMD/ATI]

       id físico: 0

       información del bus: pci@0000:01:00.0

       versión: 80

       anchura: 64 bits

       reloj: 33MHz

       capacidades: pm pciexpress msi vga_controller bus_master cap_list rom

       configuración: driver=radeon latency=0

       recursos: irq:49 memoria:c0000000-cfffffff memoria:d0000000-d07fffff ioport:e000(size=256) memoria:fea00000-fea3ffff memoria:c0000-dffff

 

Here first installation output log in https://pastebin.com/DT44j1vm and attached (so post dont get too long)   

Outcomes