andream

Error 1603 when installing driver - RX 480 Win 10

Discussion created by andream on Nov 2, 2017

If I try to install the latest driver version 17.10.3, the installation won't finish because I get the 1603 error at the end. I already followed all this guide: Error 1603 – A General Error Has Occurred During the Installation of the AMD Software Package

 

I also tried the 17.10.1 version but I get the same error. The only working version (which I have now) is the Beta for Windows 10 Fall Creators Update. If I try to update from the AMD Radeon Settings panel, it finds the 17.10.3 but at the end of the installation I get the 1603 error.

 

I had the latest version 17.10.3 this morning but since I had a problem with another software (but the issue shouldn't be related) I tried to install a previous version (17.10.1) and I did a clean installation: I thought that the clean installation would uninstall the drivers and install the "new" one but it only uninstalled, so I tried to install the 17.10.1 after the computer reboot but I couldn't.

 

I don't know if it may be related but I had a problem right after the Fall Creators update two weeks ago (I couldn't open the AMD Radeon Settings panel) but after installing the Beta driver it worked and I could update to the new versions when they came out.

 

The only important thing that changed recently on my computer should be the Windows update for Adoble Flash Player (today).

 

- Graphics Card: MSI RX 480 Gaming X, 4 GB

- Desktop or Laptop System: Desktop

- Operating System: Windows 10 Pro 64 bit

- Driver version installed: BETA 17.40-171010a-318962E-CrimsonReLive (Windows 10 Fall Creators Update)

- Display Devices: Philips 190CW, 1440x900

- Motherboard + Bios Revision: MSI H110M Pro-VD, American Megatrends Inc. 2.B0 15/12/2016

- CPU: i7-6700K

- Power Supply Unit: Corsair VS550

- RAM: 16 GB

 

Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.

Outcomes