0 Replies Latest reply on Nov 6, 2017 10:50 AM by matipunkasero

    RX570 - Ryzen 5 1600 Poor Definition and Brightness Fluctuation

    matipunkasero

      This is my system:

       

      - GPU: Asus Radeon Rx5700 4gb

      - Desktop system

      - Windows 10 64 bits (tried different versions, all the same)

      - Screen: Samsung T27A550, 1920x1080 @60hz using an HDMI cable.

      - Motherboard AB350-M Gaming 3 Bios Version F4

      - CPU: Ryzen 5 1600.

      - Power supply: Power cooler, model Silent Pro M700, 700 w.

      - RAM: 2x8gb Corsair Vengeance ddr5 2666 mhz

       

      I set up my new pc a few days ago and still can't get it to work properly. It's slower than it's supposed to be, since I bought better components than my previous pc but it runs slower, and has had problems installing programs (it installs them, but in a faulty way, for example the tray icon doesn't show, or a file is missing when I try to open the program, stuff like that). In the graphics aspect, the definition is terrible, the brightness of the screen fluctuates too much, to the point that if I watch a movie, maybe 30% or more of the scenes are almost all dark, even at a high brightness config of the monitor. Also, trying to play a game like fallout 4 on max quality results in the game running at correct speed but textures dont charge or colors appear randomly.

       

      All drivers are installed to the last update (except for bios maybe, because when I double clic on the file a message says "This file can not run in your pc").

       

      I attached two screenshots from Fallout 4 showing the problem with the textures.

       

       

      I sincerely hope you can help me, since I invested good money and effort on setting up this pc and I really look forward to enjoy it. Thanks in advance to anyone who answers.

       

      UPDATE: I installed the gpu drivers from the asus page, not amd page (ROG-STRIX-RX570-O4G-GAMING | Graphics Cards | ASUS USA

      It still runs slow but the display definition, colors and brightness is ok (not inside games, like fallout. This means the problems that are shown in the screenshots still happen). The other drivers I installed are from this page: GA-AB350M-Gaming 3 (rev. 1.0) | Motherboard - GIGABYTE  and I couldnt install the one for the bios that is offered there, like I said before.

       

      Message was edited by: Matt B We have updated the title of this discussion with relevant details to better describe your issue.