2 Replies Latest reply on Nov 5, 2017 12:08 PM by saduser

    ROCm Diasppointment

    saduser

      Well, like my username i just created this account and post because i'm very sad with this plataform (ROCm), i really wanted use it.

       

      My Problem : driver support, YOU (ROCm developers) JUST support newer cards(I have a Polaris11) in your personal kernel tree (that one you talk about in ROCm website's install instrucctions), Are so deep the changes, that you can't submit a patch ?.

       

      In general the introduction to this plataform is very vague and obscure, if you don't use Fedora or Ubuntu, you are out of luck, the instruccions for clean installation from source don't exist or if exist (i used several days digging out your ROCm website) i could'n find it, just references to several repos where you must keep reading and reading until you could figure out something.

       

      I really wanted to exploit the HSA capabilities in my graphics card, I like and support your products, but the motto of "HSA for every one" isn't true, the software stack for HSA requires a lot of changes to your base system. I thougth just was install a few plugins not at new kernel.

       

      Before hand, i'm sorry, i just need to let go out the disappointment with ROCm after a lot of time used on learn it and find that can't use it.

       

      I expect you soon submit your kernel changes to mainline, until then i must just use my graphics card for watch movies and play games.

        • Re: ROCm Diasppointment
          bsp2020

          Polaris 11 should be well supported by ROCm. What issues are you having? Did you try posting your issues on Github? People there are very responsive.

            • Re: ROCm Diasppointment
              saduser

              Hi, beforehand thanks for read and comment.

               

              Well, i thougth i was cleare which is my problem. Once again, my problem is that the support for newer cards (my case a Polaris 11 card) there isn't in the current LTS mainline kernel series (either in the stable series), the support you talk about is in the github's kernel repo of ROCm. I don't want install a kernel that don't let me keep update with the lastest stable kernel releases, ROCm project MUST provide a patch aganist it (they provide a FULL kernel) or submit the changes to inclusion (well, i don't know if they do that, but, are so deep the changes that can't be accepted by manteiners and Linus ?).

               

              Said so, without that support on mainline LTS kernel i can't use ROCm, the install from source of libraries and utilities is cumbersome (i'm not user of Ubuntu or Fedora, but not imposible and i'm up the task). Like i said before, i thougth enable ROCm was just install a few plugins on base system nor install a new kernel (for enable support and features of ROCm) and a lot the new utilities. For now (and future) just use my card (and next cards) for play and watch movies (and nice windows effects)... so sad about that, i work on software that would benefit from that extra power of GPU but no luck for me.