3 Replies Latest reply on Oct 30, 2017 7:22 AM by benman2785

    The Division + Polaris + Crimson 17.7.2 and later! - results in CRASH when using AMF with PrePass

    benman2785

      Since driver 17.7.2 Driver and/or Game crashes when using AMF with PrePass enabled. I tested 17.6.2 with the needed DLLs for AMF 1.4.6.0 (amdh264enc64.dll; amdh265enc64.dll; amdmcl64.dll; amd_opencl64.dll; amfrt64.dll) and it worked flawlessly - so i think its not AMF what is broken

       

      PLUGIN: https://github.com/Xaymar/obs-studio_amf-encoder-plugin

      CPU: AMD FX(tm)-9590@4721MHz
      GPU: RX580 4G - Sapphire Nitro+ OC @ GPU: 1411 MHz / GDDR5: 2000MHz
      RAM: 16GB Kingston HyperX DDR3 1866 CL9
      Screens: AOC G2460PF (DisplayPort) + Dell 2209WA (DVI)

       

      Win10x64 Build 16299
      OBS 20.1.1 x64bit

      LOG:
      http://benmanshafen.de/obs/xaymar/2.2.4/2017-10-27_14-55-27.7z - 4MB
      http://benmanshafen.de/obs/xaymar/2.2.4/2017-10-27_14-55-27.txt - 56MB

      Videos:
      http://benmanshafen.de/streamdl/stream-1509108943.flv - 842MB +20min without prepass
      http://benmanshafen.de/streamdl/stream-1509110256.flv - 11MB 15s with prepass - crashed

      both files are only for download - non edited - that is what my streaming server recieved from OBS

      the game and driver crashes when using prepass. i tested with reseted settings and only twitch preset with custom bitrate of 5333 // works without prepass (over 20min) // crashes with prepass (this time in 15s)


      also read:
      The Division crashes AMF & Game when using prepass - now confirmed // started with 17.7.2 - still persists · Issue #2…
      PC Crashes when trying recording "The Division" with 2.1.6 or 2.2.0 and 17.7.2 · Issue #263 · Xaymar/obs-studio_amf-enco…


      "when i cripple the old 17.6.2 (worked before - ps i know there wasnt prepass available but -> )and insert these dlls

      amdh264enc64.dll amdh265enc64.dll amdmcl64.dll amd_opencl64.dll amfrt64.dll

      it works with prepass enabled - so i think its not the AMF or the Plugin - but i cant be 100% sure - maybe i missed some dlls // yet again i think AMD has to fix their driver - maybe Mikhail can help "