2 Replies Latest reply on Nov 2, 2017 8:20 AM by amdmatt

    RX480 Crossfire Crash on Driver Install

    weebaws

      When I bought (July 2016) these cards, the driver install was done on a clean install of Windows and was smooth, then the 2nd time I installed (A month after refund period) I have had nothing but grief.,

       

      I just upgraded from 17.9.3 (I begrudged doing this as last time I had to refresh windows as nothing worked) to latest 17.10.2 and again I click on express install after performing all the recommend solutions (DDU/AMDCUU) and I get stuck on a black screen and the PC is locked up, my cards are sapphire Nitros and the bottom (2nd) GPU LED lights turn off when this happens and fails to come back on, I've had issues when i have restarted my PC and only 1 card is 'alive' on boot, then once I restart, it comes alive again, i am literally at breaking point with these cards.

       

      I have removed one card as I have had it with this joke of a card set up, and lo and behold the Driver update was flawless on install, just like my 280x days, this is a card or crossfire issue but I highly suspect a Crossfire issue as the other card works fine as i tested this theory before, can anyone please clarify with any advice or similar experiences? Raja should be ashamed for showing 2 480s beating a 1080 when many can't get past this black screen issue on Multi GPU set ups.

        • Re: RX480 Crossfire Crash on Driver Install
          weebaws

          Like to add I have tried going back a driver version and even that will lock up on black screen, I seriously do not know what more I can do to resolve this issue aside from a Windows Refresh, but I performed this for 17.9.3 as again the system locked up on restarts and black screened during Driver process, and i got lucky once, but today 7 times I wiped with DDU and it will not work.

           

          System Specs

           

          R7 1700x
          Gigabyte Aorus Gaming 5
          DDR4 2 x 8GBVengeance 3200mhz (set to optimized defaults of 2133)
          Windows 10 64 bit

           

          Like to add I upgraded from a 4790k build and I had these issues in October 2016.