2 Replies Latest reply on Oct 24, 2017 11:38 AM by identty

    AMD Crossfire NOT working with DirectX9 applications.

    identty

      Hi!

      I'm having an issue with my computer not wanting to run DirectX9 applications with crossfire enabled.

      I can run DirectX9 applications just fine with crossfire disabled.

      I have confirmed that the crash is between Crossfire and DirectX9 by testing several (DirectX9) games with crossfire enabled/disabled.

      Also tested by running Heaven Benchmark, running DirectX11 works perfectly, but when I try to run DirectX9 I get the same problem as I get with the DirectX9 based games.

       

      By using Heaven Benchmark I've confirmed that crossfire is indeed working (with DirectX11), and I'm getting great benchmark results.

       

      The cards I'm running are:

      1 - Sapphire Radeon RX 480 4GB NITRO+ (Master)

      2 - ASUS Radeon RX 580 4GB Dual (Slave)

       

      The problem I get when trying to launch DirectX9 applications can be described as a flashing black screen (1 sec) and desktop (1 sec). This flashing back and forth.

      I can however hear sound from the game menu.

       

      I have tried multiple sets of drivers including the latest Crimson 17.10.1, using DDU to remove the previous version in between attempts.

      I have also tried multiple game profiles for the different games, but all ending in the same result.

       

      My games and applications (based on DirectX9) do however run fine if I disable AMD Crossfire.

       

      This all leads me to think that this might be a driver/software related problem, but I can't figgure out how to solve it.

      Need help!

       

      Kind regards.

      Michael