9 Replies Latest reply on Oct 18, 2017 6:26 AM by kingfish

    Can't install drivers for R7 M445. Catalyst or clean update doesn't do anything.

    yjiuto4ka

      Hi.

      I recently bought Dell Inspiron 5567 (i5 and R7 M445) and for 2 weeks already can't force my R7 M445 card working.

      First of all, I installed 4xx driver from here: Download Drivers . Rebooted, nothing happened.

      Then uninstalled, Installed Crimson Relive, let him do his work, rebooted, nothing happened.

      Again uninstalled, tried clean install Clean Install AMD Graphics Drivers , step by step, disabled Windows Updates, cleaned all stuff, safe mode, etc, etc. Nothing. Happened.

       

      How can I see that nothing is happened?

      When I'm disabling my integrated HD Graphics 620, I'm having 1 Fps on mainscreen in Dota 2, my SuperPosition Benchmark doesn't load, keep saying to me you have no videocard and GPU-Z showing me weird graph when my Dedicated card working at 100% for 2 seconds, then at 0% for 2 seconds with fans for 100%, then switches back and again and again.

       

      By the way, when I'm auto-installing drivers from Relive, my card name changes to M440 and GPU-Z shows nothing.

       

       

      Hoping for help here.

      [sry for my englando]

          • Re: Can't install drivers for R7 M445. Catalyst or clean update doesn't do anything.
            yjiuto4ka

            Thank you, @kingfish, but although my current series number showing 440, its not a problem, I can install other version so it would show m445, but the idea is that both versions doesn't work.

            And yes, absolutely I tried first instruction that you linked and even clean method, I wouldn't post anything if your methods would solve problem for me.

            • Re: Can't install drivers for R7 M445. Catalyst or clean update doesn't do anything.
              yjiuto4ka

              Seems like there would be no help and no hope, but still trying again with full information now.

               

              I can't force my Radeon R7 M445 to work, no matter what. Clean method install doesn't help, which I followed step by step. If there's probabilty of remote shenanigans, go on.

               

              Describe your system:

              • AMD Graphics Card — RADEON R7 M445
              • Desktop or Laptop System — Dell Inspiron 5567-8000
              • Operating System — Windows 10 64bit
              • Driver version installed — 22.19.685.0 from Device Manager, 17.30.2822 from AMD Software

              -----


              ----

              • Display Devices

                  Have no idea how to check connections, but I think it's pointless for notebooks — 1920x1080 @60Hz

              • Motherboard + Bios Revision — 02YHJP (0x0000019D - 0x004C5E00)
              • BIOS vendor Dell Inc.  version 1.1.6  date  08/17/2017 ROM size16384 KB
              • CPU/APU — Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz Package (platform ID) Socket 1356 FCBGA (0x7)
              • Power Supply Unit  Make, Model & Wattage – No access to charger right now, but it's a common one that Dell provided with my laptop
              • RAM — 8 Gb x 1, 8ATF1G64HZ-2G3B1 , DDR4-2400

               

              Describe your issue:

              • Provide a detailed description of the issue you are experiencing and the steps required to reproduce the issue.

              I can see no proof that my Dedicated Card using drivers / Can't force it work

              • Details about applications/games affected (including version number)

              Dota 2 mainscreen – 3 fps, most other games didn't starting, SuperPosition Benchmark – 1 Fps

              • Graphical settings used in the application/game (resolution and 3D settings)

              Lowest Possible settings with 1920x1080

               

              If i something missed, hope attached CPU-Z report would have it, otherwise, I'll provide if asked.

                • Re: Can't install drivers for R7 M445. Catalyst or clean update doesn't do anything.
                  kingfish

                  You say you disabled the Intel graphics...where did you do that? You cannot do that from Device Manager...that has to be done in the bios. > HP Notebook PCs - Switchable Graphics on Notebooks Configured with Intel and ATI GPUs | HP® Customer Support

                  Do you have any yellow marks in the Device Manager?

                  Do you have the game assigned to the high performance graphics card in the Wattman control panel? How to Configure Laptop Switchable Graphics

                  NOTE:

                  New Features and Improvements

                  Radeon Settings

                  • Radeon Additional Settings has been retired and its previously supported controls for Switchable Graphics, Color Depth and Pixel Format have all been moved into Radeon Settings.

                   

                  Do you have the computer power plan set to "High Performance"? (the default is 'balanced')

                  Screenshot_12.png

                    • Re: Can't install drivers for R7 M445. Catalyst or clean update doesn't do anything.
                      yjiuto4ka

                      — Power plan.

                      High perfomance, absolutely.

                       

                       

                      — Disabling HD 620.

                      Yes, in device manager. If I should try to disable it in BIOS, I'll do it. (respectively, update drivers, turn off device (highlighted), delete device)

                       

                      —Yellow marks.

                      No there's none (because I can't do anything with disabled integrated graphics).

                       

                      — Switchable Graphics.

                      Now that's tricky one. I feel like I'm missing some settings here (probably cause of too old screenshots),

                       

                      First of all, no — there's no Dota in the list. There was no Dota in the list, till I didn't open setting, while Dota launched. Should I search or add it? Should I add every game here? Should I set high perfomance for everygame? Should I open every game with AMD Launched?

                       

                      -------

                       

                      Second, how this settings works with in-game settings? Shouldn't I feel scared about Crimson overwriting my games settings?

                       

                       

                       

                      And third.

                      How can I make sure dedicated card is working aside of disabling integrated? Because even now, when I'm disabling Integrated I have 3-4 fps on mainscreen (when integrated is on its about 20-35 fps as on screenshot above). I believe that's not the perfomance we could expect from dedicated card.

                       

                       

                      For some additional info, copying settings.

                       

                      Radeon Software Version - 17.10.1

                      Radeon Software Edition - Crimson ReLive

                      Windows Version - Windows 10 (64 bit)

                      System Memory - 8 GB

                      CPU Type - Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz

                       

                      Radeon Settings Version - 2017.1005.1719.29341

                      Driver Packaging Version - 17.30.2822-171005a-318724E-CrimsonReLive

                      Provider - Advanced Micro Devices, Inc.

                      2D Driver Version - 8.1.1.1614

                      Direct3D® Version - 9.14.10.01304

                      OpenGL® Version - 6.14.10.13492

                      OpenCL™ Version - 22.19.685.0

                      AMD Mantle Version - 9.1.10.0220

                      AMD Mantle API Version - 102400

                      AMD Audio Driver Version - Not Available

                      Vulkan™ Driver Version - 1.6.0

                      Vulkan™ API Version - 1.0.51

                       

                      Graphics Card Manufacturer - Powered by AMD

                      Graphics Chipset - AMD Radeon R7 M440

                      Device ID - 6900

                      Vendor ID - 1002

                      SubSystem ID - 0767

                      SubSystem Vendor ID - 1028

                      Revision ID - C3

                      Bus Type - PCI Express 3.0

                      Current Bus Settings - PCI Express 3.0 x4

                      BIOS Version - 015.049.000.013

                      BIOS Part Number - BR46858.006

                      BIOS Date - 2016/06/12 23:15

                      Memory Size - 4096 MB

                      Memory Type - GDDR5

                      Memory Clock - 1000 MHz

                      Core Clock - 920 MHz

                      Total Memory Bandwidth - 32 GByte/s

                      Memory Bit Rate - 4.00 Gbps

                      2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0001