7 Replies Latest reply on Feb 6, 2018 11:13 AM by ruggie74

    R9 270X not working after 17.10.1

    neszy

      I started noticing some strange things happening when playing Warframe after I updated to 17.10.1. At first I experienced an odd "tearing" effect, and then my entire screen would go black before coming back on (the screen displaying "no input" when black)... eventually it got to the point where almost immediately after starting Warframe my graphics card seemed to cut out - if I didn't close the game at this point my PC would freeze up, displaying grey and black vertical lines on the screen and responding to no input. This was fixed at the time by turning my PC off and on again, and I thought I'd fixed the issue completely after using DDU and freshly installing 17.10.1 again.

       

      The game worked for a while with no problems, so naturally I left it running when I went AFK. 30 minutes later and I came back to the same grey and black vertical lines I'd seen before. Upon restarting my PC, it blackscreened before Windows started. Restarting after this blackscreen caused Windows to load into its recovery mode so it could attempt to fix the error - this did nothing. The only thing that worked was safe mode which let me uninstall the AMD drivers I had or disable the card in Device Manager.

       

      These recent threads seem very similar to what I'm experiencing, which is why I don't think it's an isolated issue:

       

      At present, attempting to enable my R9 270X with any drivers (not just 17.10.1) causes my computer to blackscreen before Windows has loaded. Restarting leads back into the same "recovery mode" loop as I'd encountered before.

       

      Note that Windows works and loads correctly when using my motherboard's on-board graphics. Before encountering this issue I'd also received occasional atikmpag/dag.sys BSOD errors as a result of bad drivers, but that doesn't appear to be the issue in this case. My CPU is running a little hot (60-70C) due to its years of usage, so I'll be replacing my heatsink tomorrow to rule out overheating as a possible cause. Note that prior to installing 17.10.1 I had played Warframe for some 15-20 hours over a period of two weeks with no issues.

       

      Graphics Card: R9 270X

      Operating System: Windows 7 64bit

      Driver Version Installed: N/A

      Display Devices: BenQ 1920x1080, 60Hz

      Motherboard/BIOS: Gigabye 970A-UD3P / American Megatrends Inc. F1

      CPU: AMD FX-8320

      PSU: Seasonic S12II 620W

      RAM: 8GB

       

      Any help would be appreciated.

        • Re: R9 270X not working after 17.10.1
          zombiecole

          I have had the same problem after this update. I used a 280x...now it is completely dead after nearly 3 years of faultless use. Is there anything we can do about this? It seems there are a lot of us having the same issues.

            • Re: R9 270X not working after 17.10.1
              zombiecole

              ps.. we have a very similar setup....

              • Re: R9 270X not working after 17.10.1
                neszy

                Computer parts definitely don't last forever (over three years of frequent daily usage for £150 or so isn't bad), but I'm also seeing a correlation of posts which mean that something more might be going on with the drivers here. The fact that not only we but various other people have reported similar issues with this version, most of whom seem to be running an older R9-style card, does alert me a little.

                 

                So far I've completely wiped my drivers using both DDU and the AMD Clean Uninstall Utility and reinstalled various different versions to no avail (including 17.10.1 and 17.7.2, plus some older versions without ReLive). I've physically checked the GPU and even attempted to upgrade to Windows 10, which crashed at ~30% after giving me a blackscreen identical to the one I first encountered when trying to boot-up W7 with any AMD display drivers enabled.

                 

                My recommendation is either to use DDU in Safe Mode to remove all your drivers or just disable the card in Device Manager. You should be able to use your motherboard's integrated graphics for the time being.

                 

                I'm hoping there's a fixable issue here but I fear there might not be... after all, the card might've just decided to give up and there are bound to be enough people who experience some sort of "coincidence" at the time their GPU finally kicks the bucket.

                1 of 1 people found this helpful
                  • Re: R9 270X not working after 17.10.1
                    neszy

                    Update: I appear to have temporarily fixed my GPU by baking it. I haven't tried playing any games but my PC now starts correctly. I am using version 17.7.2 drivers. 10 minutes at 180-200C seems to have fixed my problems (for now), oddly enough. The R9 270X only has about five screws anyway - it was relatively simple to disassemble, all things considered.

                     

                    Update 2: About 20 minutes later my display drivers crashed. My screen turned off and on about three times but it seems to have recovered for now. I don't think I will risk playing videogames.

                     

                    Update 3: I am now 2-3 hours on. Upon attempting to play League of Legends, my video card almost immediately crashed. I decided to try logging with GPU-Z whilst playing and noticed a couple of abnormal things: my core clock dropping to 450MHz and my memory clock spiking to 1400MHz after about 10 seconds of play.

                     

                    Using AMD Overdrive I underclocked both of these things - at first I played around with only limiting the core clock, but I would still encounter a full driver crash after 5-10 seconds of playing. Further limiting of both core and memory clock (originally to 500MHz and 600MHz, respectively) allowed me to remain in-game for upwards of 15 minutes with no driver crashes. After experimenting for a little I settled on 700/800MHz limits, and my PC will now run Warframe (kinda intensive) at 60fps with no crashes. Although the GPU is at ~100% load for this, it still runs at a constant ~60fps. Temperature sits at around 60C with fan speed at under 50%. Attached are my Radeon Overdrive Settings for those that might be interested or have a similar issue.

                    2 of 2 people found this helpful
                • Re: R9 270X not working after 17.10.1
                  meiers

                  I think that those, AMD drivers may have fried the card, I have a similar MSI r9 270x.

                   

                  I have reflowed the card 4-5 times now ..every time it works for maby a week or two ...

                   

                  The MSI components er milspec and should have lasted way longer.

                   

                  Did you use fancontrol or monitored the GPU temperature. Earlier AMD drivers did not speed up the fans ... Resulting in a very very HOT running card.

                  • Re: R9 270X not working after 17.10.1
                    ruggie74

                    The same thing happened to me a couple days ago. Now I can't get beyond a black screen after the Windows logo with any AMD driver. I had no problem until updating to the latest driver... R9 270x GPU also.