0 Replies Latest reply on Oct 13, 2017 6:28 AM by bstacpoole

    Issues with RX 580 and Radeon Settings.

    bstacpoole

      First up, my specifications:

      • GPU: RX 580 8gb Gaming X
      • OS: Windows 10 64 bit Home
      • Driver currently installed: 17.7.2
      • Display Devices:

      AOC g2640PF 144hz, DPI @ 1920x1080

      Acer 60hz 60hz @ 1920x1080

      • Mobo:Asus Prime B350 plus w/ BIOS version 0902 (most recent)
      • CPU: Ryzen 5 1600
      • PSU: Corsair RM650X (Also tried a Fat Max 750W to rule out PSU issues)
      • Ram: Corsair LPX Vengeance 2x8GB

       

      My issue:

      Radeon Settings continually crash, sometimes causing the screen to flicker black and recover or to crash entirely in rare cases. Following this I usually get notifications like "Radeon Wattman settings have been restored" as well as "[APPLICATION] has been blocked from accessing graphics hardware". I have been experiencing this issue since I got my setup and have attempted troubleshooting myself but haven't had much luck.

      What I have tried so far:

      • Uninstalled drivers using DDU and clean installed every driver I can locate on the internet. Some of them seem more stable but the issue does not appear to go away (from old 16 drivers up to 17.10).
      • Adjusted Global Wattman settings to increase/decrease power.
      • Swapped out PSU for a larger one.
      • Graphics card used to be installed in my old PC and when it was it ran like a dream with no issues.
      • Tried again with a fresh install of windows.
      • Updated BIOS and reset all BIOS settings to default.
      • Run Memtest and Prime95 to ensure there were no issues with my RAM or CPU causing crashes.
      • Ran Furmark for around 10+ hours without an issue to stress test the GPU with no issues.

       

      I have been into contact with AMD customer support several times now and each response has been very unsatisfactory, they have just met me with a cookie cutter "reinstall graphics drivers, update graphics drivers" response. I am in the process of RMAing my card and will be returning it if I cannot resolve this issue. Any help or advice would be greatly appreciated.