3 Replies Latest reply on Oct 1, 2017 11:41 AM by black_zion

    a10 7850K running dual graphics with R7 240 2GB idle at 49C with H75 liquid cooler.......is this normal?

    darcevader

      Greetings AMD Community,

       

      I apologize in advance if I break any protocols and procedures as this is my first experience in a forum environment.

       

      I was just wondering if anyone has any experience with the above mentioned pairing. I understand that the CPU would run at a higher temp, but this is alarming. I have re-applied thermal paste and re-seated the block with no luck. Used HWmonitor, Coretemp, AI Suite 3, MSI Afterburner, HWInfo, and AIDA64 to monitor temps , all with inconsistant results. Running all fans at max, with waterblock plugged into system fan header (instead of CPU header). H75 mounted with hoses below the rad. Specs as follows :

       

      AMD A10 7850K

      ASUS A88X-PRO

      32 GB (4X8) Crucial Ballistix Sport DDR3 1866 PC3-14900

      R7 240 2GB DDR5 (2 monitors)

      800W TopPower 80 Bronze PSU

      Bitfenix Black Ghost Mid tower case (front panel off/mesh top insert)

      2X120mm fans intake on front

      H75 liquid cool w 2X120mm fans in push/pull (backplate inserts sanded level with mobo to ensure waterblock is flat against CPU)

       

      Fully updated Windows 10 Pro 64 bit

      Prime 95 maxes out temp at 80C in minutes

       

       

      Hopefully it's enough info to work with that someone may have suggestions other than a complete replacement of cooling solution. The H75 replaced a CoolerMaster Hyper212 EVO with push/pull.

       

      Help me Obi-Wan...you're my only hope.

       

      Thanks in advance,

       

      Darce Vader