2 Replies Latest reply on Apr 3, 2018 9:41 AM by adb1979

    BSODs during Windows 10 installation on a fresh Ryzen machine

    dmtlevin

      I have problems installing Windows 10 (and almost any other operating system) on my new freshly built Ryzen PC. The specs of the machine are:

      • CPU: AMD Ryzen 7 1700X
      • MB: Asus Prime B350M-A (BIOS ver. 0902)
      • RAM: Kingston HyperX Fury DDR4 2666MHz 2x8GB (HX426C15FBK2/16)
      • GPU: Nvidia GeForce GTX 970
      • PSU: Corsair RM550x
      • SSD: Samsung 850 EVO 500GB
      • HDD: Western Digital Red 2TB
      • TP-Link N900 Wireless PCI-E card.

      I tried to install latest Windows 10 (1703 10.0.15063) first, but got various BSoDs during installation with following errors:

      • IRQL_NOT_LESS_OR_EQUAL (x1)
      • DRIVER_IRQL_NOT_LESS_OR_EQUAL (x2)
      • SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (x6)
      • KMODE_EXCEPTION_NOT_HANDLED (x2)
      • BAD_POOL_HEADER (x1)
      • KERNEL_SEQURITY_CHECK_FAILURE (x2)
      • CRITICAL_PROCESS_DIED (x1)
      • UNXEPECTED_KERNEL_MODE_TRAP (x1)
      • 0xC000021A (x1)

      I’ve read similar threads where people suspect hardware problems, so here are my attempts to fix or diagnose the issue in chronological order:
      1. Checked both MB slots and RAM pins - no dust or oxidation.
      2. Removed one RAM stick. Installation succeeds, system is stable under various loads (two days of gaming, browsing, heavy math computations, benchmarks, stability tests etc.)
      3. Tried ALL 12 possible memory placements for two sticks, and it happens, that no matter where I put the memory modules, two 8GB sticks don’t work, while one 8GB stick does work.
      4. Set the frequency to 2400, 2133, 1866MHz with no effect.
      5. Checked each stick separately, then both together with Memtest86 - over 9 passes and no errors.
      6. Assembled a minimal setup with just MB, RAM, CPU and graphics card - nothing changed.
      7. Removed battery for 10 sec, 1 min, 10 min at various stages of my shenanigans - no effect.
      8. Installed Windows 7. At the end of installation it just suddenly rebooted and corrupted the disk partition, so I should repartition the hard drive using another PC.
      9. Installed Linux Mint 18.3. Live USB displayed Unknown hardware! error in the terminal and frozen.
      10. Installed 2x8GB kit G.Skill Ripjaws 4 Blue DDR4 3000MHz (F4-3000C15D-16GRBB) with no effect.
      11. Installed 1x16GB kit TEAM Elite DDR4 2400MHz (TED416G2400C1601), which is also in both Asus and TEAM QVL lists - no effect.
      12. Took MSI X370 Gaming Plus, but the problems were still the same.
      13. Installed Windows 8.1, and - oh, magic! - it successfully installed, addressed all 16GB of RAM, utilized all 16 CPU cores and stably worked for two days under various loads, benchmarks, tests etc. AIDA64 report also didn’t show any strange things at the first glance. I was ready to leave it, but unfortunately it does not support other software I need.
      14. Installed Ubuntu 17.04 with kernel 4.10, but it also failed with error ACPI Error: Needed [Integer/String/Buffer], found [Region] 0xFFFF.... However after booting with acpi=off parameter, it started and successfully installed the OS, but detected only one CPU core and had problems with Wi-Fi connection (but it’s a usual thing, so I guess, it’s solely Ubuntu’s problems)
      15. Brought the PC to the service. Guys from the local store, where all this crapware was bought, briefly checked the PC and said that each component is OK, and this is incompatibility problem, not a warranty case. Guys from another third-party service checked the PC and also said that each component individually is OK, but they also didn’t managed to install Windows 10 nor Linux
      16. Updated BIOS from version 0806 to 0902 with no luck.

      17. Have tried to take the latest chipset drivers from Asus website and inject them into windows 10 image using DISM and then boot with that. Didn't know what drivers to put - there are around 20 of them, - so I added all. Still no luck though - series of BSODs just after launching the installer.

       

      CPU temperature seems to be fine, as it never raised above 56 degrees under 100% load. Chipset temperature is also fine at 29~33 degrees all the time. PSU outputs correct voltages, as motherboard and guys from the service told me.

      Please help me, I'm not able to start working for three weeks and I'm quite desperate now and thinking to build a new machine, which is a ton of money.