5 Replies Latest reply on Oct 12, 2017 2:01 PM by beanto

    Graphical glitch with RX 480

    beanto

      Hi, I'm facing a very annoying problem as of 2 days ago.

       

      It happens with ANY game I try to play.

       

      I've re-installed different drivers versions at least 7 times and none of them worked, so the issue is definitely not driver related.

       

      What is happening ?:

       

      The game launches fine, but I get no reaction from it.

      It's like a permanent frozen image.

       

      The game(s) only react if I change tab and then go back to the game. It's as if changing tab would allow me to advance a few frames further.

       

      I've already tried changing the in-game display options and it didn't solve anything.

       

      I made a video showing my problem so that you could understand what I mean.

       

      I've also posted pictures of my specs.

       

      Thank you in advance for your help !

       

      AMD Graphics Card

      Make and model; Visiontek rx 480 8Gb

       

      Operating System

      Windows 10 Pro 64bit

       

      Driver version installed

      Radeon Software Crimson Relive 17.9.3

       

      Display Devices

      HP Envy 34" 2015 Model 3440x1440 @ 60HZ - HDMI to HDMI connection

       

      Motherboard + Bios Revision

      Gigabyte LGA 1151 Z170

      American Megatrends Inc vF6, 2016-02-23

       

      CPU/APU

      Make and model number

      Intel i7 6700k

       

      Power Supply Unit  Make, Model & Wattage

      Cooler Master 80+ Bronze G650M - 650Watt

       

      RAM

      24GB DDR4

       

       

      AMD RX 480 Graphical glitch - YouTube

       

      ss (2017-09-29 at 06.26.31).png