AnsweredAssumed Answered

Why is VME still broken on my Ryzen system?

Question asked by stacey.leibermann on Sep 19, 2017
Latest reply on Feb 6, 2018 by stacey.leibermann

I bought a 1700x with a Gigabyte Gaming 3 motherboard.  I updated BIOS to whatever the new one was at the time (I think F5), and my computer worked well; RAM overclockability was garbage, but I didn't really care @ the time.  Chip hasn't been overclocked yet (it is currently plenty fast for my needs), it's cooled with a Noctua D14 cooler (generally doesn't go over 50°C), RAM is 2933 (currently 2133 after the BIOS update), and my system will pass every benchmark/stress test that exists.

 

I built my system, and after a few days of stability testing, I installed Hyper-V, and created a few VMs, and noticed that all of the x86 VMs will crash the host OS in a few minutes.  Popped on Google, saw this was caused by AMD's improper implementation of VME.  I have been using Win x64 VMs for months now, as well as a bunch of Linux ones, with no issues, so it seems very likely VME is the issue, or some other instruction set that Win x86 uses that x64 doesn't.

 

A few months ago, AMD claimed there was a VME fix with microcode 8001126.  As soon as I could, I downloaded the update that had this microcode (AGESA 1.0.0.6a); same issue.  E-mailed Gigabyte on July 5th, and they replied on July 10th saying the fix was coming with AGESA 1.0.0.7 (I have a feeling they meant 1.0.0.6b?), so I waited.  BIOS F8 came (I never installed this one, since it had no AGESA update), then F9D came, which had AGESA 1.0.0.6b.  After updating to this F9D BIOS, I verified that I got new microcode 8001129 (verified with HWInfo64) ... still the same issue.

 

I posted on reddit, and others still have the same issue with their updated BIOS on their boards.  Is the problem my CPU, or is my problem my motherboard?

 

Another random tidbit: when I was originally trying to display the current microcode for my CPU, I ran SiSoftSandra's processor information tool (it's not benchmarking the processor, but rather seems to be trying each instruction for capabilities) and it consistently crashes my system after maybe 40 seconds.

 

I'd really like to know what my options are.  I actually "need" Win x32 OSes for a bunch of VB scripting in Excel/AutoCAD that are considerably faster in Win x32 than x64.  I mostly used Win 7 x32 VM OSes, but I tried Win 10 x32 for comparison, and it crashes the same.

 

Edit: Bought my CPU/motherboard Apr. 29, 2017

Edit 2 (Sept. 20):

OS: Windows 10 x64 Pro w/Hyper-V installed (fully updated)

CPU: AMD Ryzen 1700x running stock everything, (CPUID: 00800F11, Stepping: ZP-B1, Microcode: 8001129, SMU Firmware: 25.82.0)

Motherboard: Gigabyte AB-350-Gaming 3-CF (BIOS F9D; issue exists in all BIOS) (AMD 17.30 drivers installed)

RAM: 16GB (2x8) of Corsair CMK16GX4M2B3200C16 running 1066/15/15/15/36/51 (default)

GPU: MSI GTX 1070 Gaming X (stock everything) (nVidia 22.21.13.8476 drivers installed [384.76])

Drives: Samsung EVO 960 500GB NVMe, Samsung Evo 840 256GB, 2x Toshiba MD04ACA500 5TB (non-RAID) (Samsung v2.2 driver installed)

Monitors: 3x Dell U2412M @ 1900x1200

USB stuff: (USB Host 1: Logitech Keyboard, Mouse, Garmin watch, USB stick ... USB host 2: APC UPS, HP LaserJet 1020) (All Microsoft drivers)

 

Using the Ryzen Balanced power profile, but using High Performance changes nothing with respect to my issue.

Outcomes