1 Reply Latest reply on Sep 16, 2017 12:31 PM by jetgraphics

    RX470 screen tearing in Win7

    jetgraphics

      Issue: annoying glitch - screen tearing - approximately 2/5th from bottom of screen while showing 1080p@60Hz.

      Appears regardless of software (VLC, BeyondTV, YouTube).

      Appears on LCD video projector and LCD TV/Monitor.

       

      Radeon RX470, 4 GiB

      AMD FX-8320 8 Core CPU

      16 GB DDR3

      ASROCK 970 EXTREME3 MB

      Crimson ReLive 17.30.1041-170720a-316469C

       

      TEARING video on 1080p Projector & UHDTV only became noticeable after reverting from Win10 => Win7.

      This leads me to assume it is a software / driver incompatibility issue, and not related to hardware.

      And since it was a NEW install with up to date drivers, there should be no issue with old drivers.

       

      When I tried to make a screen capture (at 30 fps), the captured image showed no tearing.

       

      Global Settings:

      Anti-aliasing Mode - Use application settings

      Anti-aliasing Method - Mutlisampling

      Morphological Filtering - OFF

      Anisotropic Filter Mode - Use application settings

      Texture Filtering Quality - Standard

      Surface Format Optimization - ON

      Wait for Vertical Refresh - Always ON

      OpenGL Triple Buffering - ON

      Shader Cache - AMD optimized

      Tessellation mode - use application settings

       

      What is most frustrating - my low budget Celeron G1840 with integrated graphics can display 1080p@60Hz with NO TEARING.

       

      P.S. - is there documentation / manual for Catalyst / Crimson that goes into detail on what each setting is and does?

        • Re: RX470 screen tearing in Win7
          jetgraphics

          DIAGNOSIS: Ran Youtube video of a screen tearing TEST PATTERN at 60fps, and one at 29.97 fps.

          https://www.youtube.com/watch?v=5xkNy9gfKOg

          Tearing at 60 fps, but 29.97 was miserable. . .

          HOWEVER

          When I closed BTV, and AERO came back on, 29.97 fps was error free.

           

          PROBLEM: Autoswitching to Basic from Aero results in screen tearing.

           

          RESOLUTION : Turn AERO back on.

          (I could not find any means to prevent AERO autoswitching to BASIC)

           

          Open your registry, find the following location (you create the Restart Aero and Command folder).

           

          HKEY_CLASSES_ROOT\Directory\Background\shell\Restart Aero\Command

           

          Create a new string in the Command folder, and leave it named (Default), then under Data, type the following:

           

          CMD /C NET STOP UXSMS & NET START UXSMS

           

          That adds the option to Restart Aero to the right click context menu when you're on the desktop.

          . . . .

          WORKS ! ! ! ! !