2 Replies Latest reply on Sep 2, 2017 7:22 AM by daquansmotherinlaw

    Please help!!! Amd catalyst control center wont open

    daquansmotherinlaw

      Okay so i will explain this from the start and put every little detail in so you guys can help me out.

      I bought a new game and i started playing it. My pc has intel 4000 and those were the minimum graphics required to play the game. I wanted more fps so i decided to switch to my amd radeon 7650m hd graphics card instead. I clicked the switch graphics button on the right click menu on the desktop. Nothing happened. I tried to open ccc and nothing happened. So i went to my ccc2_install folder and clicked setup and tried to re install ccc. It uninstalled everything and installed it back. I noticed my switchable graphics option was gone and i still could not open ccc. I kept on installing and it would not open. Giving me an error saying AMD Catalyst Control Center cannot be started and there are currently no settings that can be configured using AMD Catalyst Control Center. I went online to find answers and a youtube video told me to do a disk cleanup. I started the cleanup but then thaught it would delete every thing so i quickly stopped it. I then went on to restore my laptop back to the state where i had ccc and switchable graphics option. I clicked it and tried to restore. It was giving me an error. Then suddenly everything disappeared and i realised my mistake. When i did the cleanup it got rid of all my restores. So i was stuck there. I have tried to reinstall it andeverthing but it does not work. Amd catalyst control center wont open and i cant switch my graphics. And now that i try to launch m game it says. Blocked loading file aticfx64.dll or something like that. I know thats an intel thing so i think its messed up my original driver too. I am stuck and cant do anything. Please help me get ccc and configre switchable graphics option back.  and if you could help me with my game error that would be also very good. Thanks, please help im stuck and cant do anything