2 Replies Latest reply on Aug 31, 2017 11:58 AM by nb70

    Ryzen 3 new build won't boot up, any ideas?

    nb70

      I am experienced with PC builds but not with Ryzen.

      I am current using:

      • a Ryzen 3 1300X CPU,
      • an ASUS Prime B350-PLUS mother board,
      • a ZOTAC Geforce GTX 1050ti mini graphics card (plugged into the grey PCIeX16_1 slot),
      • 2 off SK hynix 8Gb 2133 Mhz RAM (plugged into slots 2 & 4) and
      • a 550W power supply (with 1 x 24 pin connector, 1 x 4 pin connector, 2 x SATA connectors and 3 X MOLEX  connectors).

      All connections, cards, front panel wires and CPU are installed correctly and checked.

      When powered up the power LED lights up, the LEDs at the graphics card ports light up, fans on the CPU, graphics card, case, power supply start up and the Hard Drive powers up but I get nothing on the monitor or a boot up.

      I'm not sure if I require a power supply with an 8 pin connector and not the 4 pin (which I was lead to believe is compatible with the Ryzen mother board) and it appears the reset button on the case doesn't operate (although this might be a separate issue).

      Is anyone able to point me in the right direction please?

        • Re: Ryzen 3 new build won't boot up, any ideas?
          gkeawe

          The 8-pin power connector is required. What is the model of the power supply? some power supplies come with two separate 4-pin  power connectors that connect together to make the 8-pin connector that is used on the motherboard. If it doesn't have them, you'll definitely need to get a power supply that has an 8-pin connector. Keep me updated.

            • Re: Ryzen 3 new build won't boot up, any ideas?
              nb70

              Hi gkeawe, apologies for the delay! I changed the power supply and still nothing. I also tried the recommendations using only 1 RAM and checked the version of BIOS on the motherboard (which was more than up to date) and still nothing. I am thinking that either the motherboard is a dud or the CPU.