2 Replies Latest reply on Aug 25, 2017 1:06 AM by rodentventura

    7970 100% usage and overheat on all games.

    rodentventura

      MSI Radeon 7970 (3Gb) (Running from DVI)

      Windows 7 Pro

      Intel I7 950 3Ghz

      24Gb DDR3

      Asus Rampage III Extreme - BIOS Ver. 0901

      Thermaltake TRX1000 (1000 Watt)

       

      I'm having an issue with my machine that I can't pinpoint, so I'm trying here first and working my way down the line.

       

      Games that used to be trivial for my computer to handle have become unplayable for unknown reasons, The GPU usage skyrockets, as does the temp when launching simple games such as Running with Rifles, S.T.A.L.K.E.R., and Dawn of War: Soulstorm. Even when not under any kind of load what-so-ever I get great amounts of artifacting, that for some reason is predictable. If I bob an explorer window around off screen, then my icons get skewed in a cool, but terrifying way.

       

      GPU usage hovers around 0 - 5%  when idle, and the temp is normalizes around 42C

      When playing a video in a browser, usage is erratic at ~10-55%

       

      Troubleshooting I've done so far includes: Checking PSU rail voltages, Trying another known-good-working card, Driver reinstall (clean), Windows 7 reinstall, Moving card to different slot, Switching to aux motherboard BIOS, and a different monitor.

       

      The Tahiti.rom in one of the images I have is a backup of the card's BIOS, I was planning on re-flashing it, but never did.

       

      Once again, I've tried 2 7970's but get the same result!

       

      I can't for the life of me figure out what's wrong, can any of you help me out?

      If you need any more information, I'd be more than happy to provide as much as I can.