AnsweredAssumed Answered

RX 480 BIOS flash driver problem

Question asked by jhrr on Aug 23, 2017
Latest reply on Aug 30, 2017 by ray_m

Hello there and sorry for my bad english advance.


My setup: Win 10 Pro x64, i5-6600k@4.5, ASRock Z270 Pro4, 16DDR4, RX480

I'm looking for help cause I searched many forums already and found nothing useful for me.

When I tried to update my RX480 bios (via ATIflash (latest)) to improve my memory timings (for better Witcher 3 fps), something went wrong. Flashing process done correctly, but verification gave me 01FL error. I rebooted the system, got black screen. Meh. Add a jumper on a first and eight pins of the BIOS chip and reboot the system again.

Okay, we have card back alive, POST screen, fail-state in ATI flash, flashing the card with the old BIOS, the new bios, the any bios i can fit to it - no effect.

Card won't plug into the system - radeon control center, driver won't start ("radeon settings are currently not available", in system device manager card have error 43).

How can i fix this?

In GPU-z i have 0Mhz Cclock and Memclock, "off" on checkboxes Opencl and Directcompute, but I can download my BIOS via gpu-z interface...

I already tried DDU, clean install, older version of Catalyst.

Card directly plugged into my monitor via HDMI. iGPU turned off. PCIE primary. RX480 my only one card in system. Video output from RX480 are working (i wrote this, right, huh?), so, it's very likely, pure driver problem, cause i can flash any BIOS without a hitch and can upload it to my HDD from card.

Have no idea what i should do next. Any help, please. I'm stuck.


Count for your assistance, with respect, J.