12 Replies Latest reply on Aug 30, 2017 11:18 AM by ray_m

    My games are lagging after installing graphics drivers

    fyzik

      So i have bought Amd R7 250 and installed graphics drivers and windows start menu started lagging and games are lagging too. When i run the game it almost looks like the graphic card doesnt work and cpu does everything, even rendering. When i looked into Crimson program it shoved 0% graphic card usage, but if i run only working game it shows like 50% usage(in this game graphics card is working perfectly). The same problem appeared even before i bought the graphics card, it happend when i installed Windows 10 but it fixed itself that day ,but now not. And something i have set in BIOS integrated graphics card as primary because without it it doesnt even POST and the fan on graphics card every 10-15 seconds starts spinning on 100% for like 0.3 second and then goes back to normal and after next 10-15 seconds it happens again and again and again......

       

      PC:

      AMD R7 250

      Its a desktop computer

      Windows 10 64-Bit

      Radeon Software Crimson Edition 17.7.2

      AMD Athlon II X2 B26 3.20GHZ

      Evolveo Pulse 450W

      8GB of RAM (I think Its Samsung)

       

      EDIT: This shouldnt happen in Win7 but for some reason the only Win7 i could install was 32-Bit and nothing worked on it

      EDIT 2:I have sucesfully installed Win7 64-Bit + all windows updates + graphic card drivers AND ITS THE SAME, games doesnt run because there isnt DirectX 9c

      BUT i have there DirectX 11 and if i install DirectX 9c its says THE SAME THING.

      EDIT 3: My research: CPU is rendering what should render Graphic Card - YouTube

                 This wasn't happening till i installed graphic card drivers and uninstalling them doesnt help.