21 Replies Latest reply on Aug 30, 2017 1:05 PM by ray_m

    Witcher 3 - AMD Radeon settings NOT overriding

    prospector

      Yes so, as odd as it is (especially to me) I noticed with Withcer 3, if the setting such as "antialiasing" is not on in-game (or in-program whichever you prefer), BUT Radeon Settings says it is on,  (say to Supersampling or multi-sampling) it will not come on inside the game.  Same thing.. well.. with EVERY setting.  Anyone have any ideas why this is?  I mean otherwise my performance is fine (of course with the latest update (17.7.2) the water flickers, but if I turn off anti-aliasing in-game it goes away)

       

      So... is AMD or whatever company made the Witcher 3 just refusing to allow AMD cards to use their own settings because of all the complaints of Witcher 3 not running well? 

        • Re: Witcher 3 - AMD Radeon settings NOT overriding
          black_zion

          Not every game accepts overrides.

            • Re: Witcher 3 - AMD Radeon settings NOT overriding
              prospector

              Well I thought having the option there, to override.. is the point of that?  lol... to "override" means to take over... why would you call it "override" then?  I mean...

                • Re: Witcher 3 - AMD Radeon settings NOT overriding
                  black_zion

                  Except The Witcher 3 has an in game option to enable or disable AA, and by disabling AA it...disables AA.

                  1 of 2 people found this helpful
                    • Re: Witcher 3 - AMD Radeon settings NOT overriding
                      prospector

                      And when I choose to enhance AA it doesn't enhance AA.  When I choose to OVERRIDE the AA, it doesn't OVERRIDE it... even when I choose to override it with something else.  In other words it doesn't matter what I do, the override option doesn't work.  Nor does... ANYTHING.. 

                        • Re: Witcher 3 - AMD Radeon settings NOT overriding
                          prospector

                          It would be nicer, and better, to have super samping on instead of the lame AA that the game may provide.  Also, I don't think your argument works well because I can override other games, even with the AA off in-program/game. 

                            • Re: Witcher 3 - AMD Radeon settings NOT overriding
                              kingfish

                              Also, I don't think your argument works well because I can override other games, even with the AA off in-program/game. " Then it sounds like a problem with the game...or your computer...what do you have anyhow?  INFORMATION REQUIRED WHEN POSTING A QUESTION

                                • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                  prospector

                                  AMD GPU - 2x RX 480

                                  AMD CPU - FX 8350 Eight Core

                                  Gigabyte Mobo

                                  8 Gig of RAM

                                   

                                  It's not a problem with my computer, because it does the same exact thing on other computers I've used..  What other info you want? 

                                    • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                      kingfish

                                      It would have been nice to know this is a crossfire issue. Another reason/example why the Crossfire sub-forum should be brought back ray_m

                                        • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                          prospector

                                          Not sure lemme give that a shot (the crossfire thing)... btw here is some more info... all the "required" info isn't going to help my issue anyways... 

                                           

                                          AMD GPU - 2x RX 480

                                          AMD CPU - FX 8350 Eight Core

                                          Gigabyte Mobo

                                          8 Gig of RAM

                                          Windows 10 64 bit Home

                                          850W Thermaltake PSU

                                          • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                            prospector

                                            So no difference.  I did discover something interesting though....

                                             

                                            My framerate didn't drop like I thought it would.  With AA either on or off using single, not in crossfire mode.  Also something else, I discovered that if I only use that 1 card the game freezes, I alt-tab out... go back in and it's working again.  It's completely random too, happens 30 seconds in the first time, then 3 minutes in.. etc... anywho. 

                                                • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                  prospector

                                                  I'm a little confused... why did you post that?  I read some of it though, still don't get it. 

                                                    • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                      kingfish

                                                      Because if you don't have the power limit set to off (+50 or whatever) you are telling the card to throttle when the action gets hot. You are drawing more power then...and the actions of two cards , crossfire, (great idea ATI...sell them two) are not reproducible with a single card. And ULPS is a basic setting for crossfire owners. What else?

                                                        • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                          prospector

                                                          I have the power limit set to +50 and have my cards both overclocked.  Thus far, the highest my wattage has ever been in 736W... I tested this by plugging a wattage tested into my outlet and measuring the wattage while my wife played a very intense part of a game (not Witcher 3, because Witcher 3 for some reason never seems to use the full power of my cards)...

                                                           

                                                          My temperature on my cards never goes above 78. 

                                                            • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                              kingfish

                                                              Can I be honest? Why don't you use one card while playing that game? Have we forgotten that most/all PC games are designed to be 'playable' at 30fps? I can promise you my games look no different (that I can tell) when I get 100+ fps than they do at 60fps. Yes, I use VertSync ...and don't understand why everyone doesn't.

                                                              And again, this seems to be a issue with crossfire and not the majority of users who have one graphics card....whether that is caused by AMD or the Game Developer is irrelevant. The solution is to disable crossfire.

                                                                • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                                  prospector

                                                                  Because I like to hear my computer struggle.  lol jk it doesn't do that.  I mean I guess I can... I just don't like to.  But honestly, I guess it doesn't matter... for that game anyways.   I just want my radeon settings to be able to override settings in the game, like that's what override means and I think that's what it should do but it doesn't. 

                                                                    • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                                      colesdav

                                                                      Hi ...

                                                                       

                                                                      I tested The Witcher 3 : Wild Hunt ~ start of this year and it was working great in Crossfire on Dual R9 Nano and i7-4770K.
                                                                      There was bad flickering on some textures  if I used the in game anti-aliasing and I found the only way to get rid of the flickering in Crossfire was to turn
                                                                      off the in game AA and use AMD Settings to Override Application Settings and I set the AA quality instead and that did seem to work then.
                                                                      Changing the AA quality level in Radeon settings did change the graphics quality and did impact FPS.
                                                                      I will have to check what OS I was running ... It was either windows 8.1 64 or *might* have been Windows 10.

                                                                       

                                                                      Maybe something has changed since then inn The Witcher 3 :Wild Hunt or
                                                                      I was trying Radeon Chill with Crossfire a few weeks ago on The Witcher 3 (There are problems with that... )

                                                                      I can take a quick look to see if the AA override is working for me.

                                                                       

                                                                      Has your gaming caused any crashes recently?
                                                                      I would remove your graphics Drivers, run amdcleanuputility.exe and then download and install fresh driver and test that.

                                                                       

                                                                      Regarding "Why do you even bother to run Crossfire" ...
                                                                      Because if I want to run "The Witcher"  on Ultra Settings with everything maxed out I can only hit around 30 - 45 FPS with 1 R9 Nano with it's Power and Fan settings maxed out.
                                                                      Different people have different reaction times and visual responses.
                                                                      To me, running the Witcher at ~ 30 - 45 FPS feels laggy/ slow response.
                                                                      Running two cards in Crossfire I get ~ 50 - 80 FPS. more importantly I can use FreeSync as well.
                                                                      The gaming experience is better.

                                                                       

                                                                      Cheers.

                                                                      • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                                                        colesdav


                                                                        I took a look into this for you this evening running on i7-4790K and two R9 Nanos. I am running on Windows 8.1 64bit with 17.4.4 Crimson ReLive WHQL.
                                                                        I will look at Windows 10 64 bit with the very latest drivers next. it appears AMD are now forcing me to game on Windows 10 as the 17.7.2 is still not available for
                                                                        Windows 8.1 64 bit.

                                                                         

                                                                        I tested at 1080p and 4K Virtual Super resolution on a 1080p FreeSync Monitor set to 44-60Hhz range, and then repeated with the monitor set to 44-75Hhz.
                                                                        I decided to focus on testing at 1080p though, I find it is easier to see the effect of AA at lower resolutions.

                                                                         

                                                                        FreeSync On using Displayport.

                                                                        All game settings on Ultra.

                                                                        In Game Post Processing AntiAliasing turn on or turned off during testing.

                                                                         

                                                                        Radeon Crimson Settings.

                                                                        I set all options in AMD Global Settings first.
                                                                        I then went into the Witcher 3 profile and reset all settings to match the global settings.

                                                                        I launched the Witcher 3 from the profile settings.

                                                                        I checked visually what was going on and monitored the FPS using in game FPS in Steam and also verified with Fraps.

                                                                         

                                                                        My conclusions so far.

                                                                         

                                                                        1. The behaviour of AntiAliasing has changed in the game since I last tested it. 
                                                                        2. Turning off AA in the game and overriding the AA Settings (I tried various combinations) does not appear to have any visual or FPS change.
                                                                        3. Overriding AA does not work using Crossfire Global Settings on or off.
                                                                        4. The overriding in game AA settings issue failing to have any affect at all and is independent of Crossfire setting.
                                                                        5. With the in game anti aliasing turned on I see the following

                                                                         

                                                                        5(A).  With Crossfire Off in Global Settings. When I turn the In Game AA on  I can see a shimmering effect on trees and bushes whilst the character is running forward. Similar to a moire pattern. In other words, there is a visual issue with the in game AA even when Crossfire is off.
                                                                        5(B). With Crossfire on in Global Settings.  When i turn the In Game AA on the moire effect is slightly worse and sometimes I see minor low frequency flicker. 
                                                                        It has significantly improved (reduced) since last time I tested it though.It is still to annoying for me to put up with it though.

                                                                         

                                                                        I have only looked at the Witcher 3 and I have not looked at 17.7.2 on Windows 10 yet.
                                                                        I do not know if AA Override is broken / disabled for everything now. I would have to try another game.

                                                                        I will look at the behaviour running it with FreeSync off over HDMI cable as well.

                                                                        Time to file an AMD Report form if you want to get AA override working. AMD Issue Reporting Form

                                                                        I will file one as well.

                                                                         

                                                                        Bye.

                                                                        1 of 2 people found this helpful
                                          • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                            ambrose

                                            Hi Prospector,

                                            Have you asked this question on the Witcher Forums, They are a great bunch there. I am using a single card to play my Witcher 3. Before it was a Sapphire R7 260X, then I recently got my HD 7870 GHz Edition up and running again, and I find Witcher 3 plays good for me. ( With Either Card ) I am not sure how you start your games but I use GOG via the GFX card Profile Adding and start my game from the GFX Global control panel, and I don't do any O.C.'ing to speak of. Again they are a great bunch over on the Witcher Forums I encourage you to drop a line there.

                                             

                                            Cheers, Ambrose

                                            2 of 2 people found this helpful
                                            • Re: Witcher 3 - AMD Radeon settings NOT overriding
                                              ray_m

                                              MODERATOR NOTE:  I am glad to see you have resolved your issue. To help keep this post on topic and help other with a similar issue, I am locking this thread.